Hi, ich möchte in Excel wenn ich einen bestimmten Begriff eingeben, dass er sich dann zu diesem Begriff den Wert von einer anderen Tabellenmappe holt. Geht das?

...komplette Frage anzeigen

3 Antworten

Wenn du z. B. in Tabelle2 stehen hast  

  |    A         B
--+-----------------------------
1| BMW Mercedes
2| 15 12

dann nimmst du als Formel

=WVERWEIS(A1;Tabelle2!$A$1:$B$2;2)

(Wobei es meistens übersichtlicher ist, solche Tabellen untereinander anzuordnen, dann sieht die Formel bei z. B. 120 eingetragenen Marken so aus:

=SVERWEIS(A1;Automarken!$A$1:$B$120;2)

Du kannst auch auf andere Arbeitsmappen (Excel-Dateien) zugreifen mit

'[Name der anderen Datei.xls]Name der anderen Tabelle'!$A$1:$B$120

statt

Tabelle2!$A$1$:B$120

- die Hochkommas (') um Datei- und Tabellenname sind erforderlich

)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von KaiserWilhelmXL
22.03.2016, 10:38

Wow, das sieht super aus. Ginge es das so in der Tabelle2?

  |  Automarke   2012   2013
--+-----------------------------
1| BMW 140 145
2| Mercedes 150 200
3 Porsche 160 175
 4 usw. usw. usw.

Und in der 1. Tabelle gebe ich dann manuell die Daten ein:

 | Automarke Jahr Wert
--+-----------------------------
1| BMW 2012 .....
2|
3
 4

Ich hoffe, das ist so verständlich. Vielen Dank.

1

Hallo,

wie bereits gesagt wäre es besser wenn du die Tabelle Hierarchisch neben einander anordnest.

Sprich,

Tabelle2:
A1=Markenbezeichnung
B1=Zahlen

So, jetzt hast du in derTabelle1 sagen wir mal in der Zelle A1 ein Eingabefeld.

Da gibst du die Automarke ein (z.B. BMW)

In die Zelle B1 in der Tabelle1 gibst du folgende Formel ein:

=SVERWEIS($A$1;Tabelle2!A2:B200;2;0)

So bekommst du immer die Zahl die hinter der Marke steht.

Grüße,

iMPerFekTioN

Antwort bewerten Vielen Dank für Deine Bewertung

=sverweis(a1;Tabelle2!A:B;2;falsch)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von KaiserWilhelmXL
22.03.2016, 10:21

Genau, sowas suche ich. Kann den SVerweis noch mit dem jeweiligen Jahr ergänzen? Danke.

1
Kommentar von Dano9889
22.03.2016, 10:21

Er hat die Zahlen ja in A2 und nicht in Spalte B ;)

0

Was möchtest Du wissen?