Hi, ich möchte gerne in MS Excel die Uhrzeit ab der Sek. 30 aufrunden, bzw. ab 29 abrunden. Zusätzlich wenn unter 1 Minuten dann erst ab 15 Sek. aufrunden?

...komplette Frage anzeigen

1 Antwort

Teste mal genau:

=WENN((A1*24*60)>1;RUNDEN(A1*24*60;0)/24/60;WENN((A1*24*60)>=15/60;1/24/60;0))

Ich schau später noch mal, ob ich es etwas eleganter hinbekomme.

KaiserWilhelmXL 20.11.2017, 10:11

Hi, ich habe dazu noch einmal eine Nachfrage.

Nun habe ich die Zahl 4,12708333333333 -> die formartiert [h]' mm -> zu 99'03 wird.

Könntest du deine Formel anpassen, so das für meine neuen Zahlen auch mein gewünschtes Ergebnis zustande kommt?

0
Oubyi 20.11.2017, 13:18
@KaiserWilhelmXL

Sorry, das verstehe ich nicht.
Das ist doch richtig so.
Die Zahl entspricht genau 99 Stunden und 3 Minuten.
Meine Formel geht davon aus, dass der Wert in A1 als Zeit eingegeben wird.
Was soll die Kommazahl den sonst heißen?
Welches Ergebnis wünscht Du Dir denn?

0

Was möchtest Du wissen?