Hi, ich möchte gerne bei Excel immer bei einem bestimmten Nachkommawert runden.Geht das?

... komplette Frage anzeigen

4 Antworten

Würdest du bei 30 Sekunden runden, wäre es einfach:

=VRUNDEN(A1;1/24/60)

So könnte man die Sekunde vor der 30 als Sonderfall einführen:

=VRUNDEN(A1+(SEKUNDE(A1)=29)/24/60;1/24/60)
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Suboptimierer
22.03.2016, 14:53

Achso, verstehe. Immer wenn die Sekunden kleiner 29 sind, soll 1 Minute zurück gegeben werden, sonst auf die nächst größere Minutenzahl aufgerundet werden.

=WENN(SEKUNDE(A1)<29;1/24/60;ZEIT(STUNDE(A1);MINUTE(A1);0)+1/24/60)
1

Dein Format kannst du noch einstellen:

=TEXT(RUNDEN(31*(1/24/60/60)+A1;8);"m")

Und fals die Anzahl der Nachkommastellen nicht reicht darfst du das natürlich erweiter :)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von iMPerFekTioN
22.03.2016, 11:58

@Ghanasoccer,

kannst du mir mal deine Formel erklären? Ich steig nicht dahinter =D

Würde mich aber echt interessieren =)

Grüße,

iMPerFekTioN

1
Kommentar von Ghanasoccer
22.03.2016, 14:50

momentan steht "m" als Einheit/Form. entweder lass es weg und formatier es ganz normal wie dus kennst oder du machst andere tollere Sachen draus. am/pm hh:mm:ss usw.

0

Also ich hätte da Folgende Formel:

Du überprüfst die letzte Zahl (die erste von Rechts) ob es eine 9 ist oder nicht,

Falls ja, wird aufgerundet, falls nicht wird abgerundet.

Dazu dann die Formel:
In meinem Beispiel steht die Uhrzeit in A1 und die Formel in B1

=WENN(RECHTS(A1;1)="9";AUFRUNDEN(A1*24;0)/24;ABRUNDEN(A1*24;0)/24)

Grüße,

iMPerFekTioN

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von KaiserWilhelmXL
22.03.2016, 12:34

Klingt gut. Aber es soll erst ab 29 gerundet werden und nicht wenn immer eine 9 hinten steht, z.B. bei 19.

Und könntest du noch mit einbauen, dass immer unter 0:29 -> 1:00 ist. Du bist klasse! Danke

1
Kommentar von DeeDee07
22.03.2016, 13:31

Du musst da sehr aufpassen mit Textfunktionen (RECHTS) bei Nicht-Textformaten (Uhrzeit).

Wenn in A1 z.B. 00:29 steht (als Uhrzeit), dann liefert die Formel =RECHTS(A1;2) den Wert 89.
Warum? Zeiten sind in Excel als fortlaufende Zahl formatiert. Eine Tageslänge = 1.
00:29 sind 29 Minuten, also 29 / 1440 = 0,020138889

2

Uhrzeit runden hat mich selbst interessiert
http://praxistipps.chip.de/excel-uhrzeit-auf-und-abrunden_33975

=WENN(SEKUNDE(A1)>=29;AUFRUNDEN(A1*1440;0)/1440;ABRUNDEN(A1*1440;0)/1440)
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von KaiserWilhelmXL
22.03.2016, 11:36

Super, es funktioniert. Kann ich Formal noch ergänzt, sodass ein Wer unter 0,29 immer bei 1 liegt? Danke

1

Was möchtest Du wissen?