Hallo, kann man in Excel eine Art Variable festlegen die einen Wertebereich an z.b. die MITTELWERT Funktion übgibt?

... komplette Frage anzeigen

2 Antworten

Um alle Werte einer Spalte zu nehmen, verzichtest du auf die Zeilenangabe, und zwar so: =MITTELWERT(A:A)
Funktioniert in Excel, aber nicht in Open-/LibreOffice

Für die Dynamik verwendest du den INDIREKT-Befehl

Für gleichmäßig benannte Tabellenblätter und gleiche Bereiche brauchst du nichtmal eine Bezugszelle, sondern kannst z.B. verwenden:

=MITTELWERT(INDIREKT("Tabelle"&ZEILE(A1)&"!A:A))

Diese Formel kannst du nach unten kopieren, so dass in jeder Zeile der Mittelwert des nächsten Tabellenblatts steht (sofern sie Tabelle1, Tabelle2, Tabelle3... heißen)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Erothh
10.02.2016, 13:16

Vielen Dank :)

Mein Problem ist jetzt ich verwende INDIREKT so oft das meine Excel Datei ~10Minuten zum berechnen brauch...

Ich habe gelesen das ich stattdessen INDEX nutzen kann, hab aber nicht herausgefunden wie.

Und zwar will ich genau das gleiche machen in Zelle A1 sagen wir mal steht Tabelle1!H:H.

Das Verwende ich z.b. so

=MAX(INDIREKT(B2))

Wie kann ich das verwenden das INDEX genau die gleiche Funktion hat?

0

Du kannst mit INDIREKT Textausdrücke in Bereiche umwandeln.

A1: Tabelle1!A2:A93
B1: =MITTELWERT(INDIREKT(A1)) 
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Jackie251
02.02.2016, 17:50

fast schon erschreckend wie schnell du antwortest :-D

2

Was möchtest Du wissen?