Hallo zusammen, wie kann man in Excel mehrere Werte miteinander verknüpfen und trotzdem unterschiedlich auswerten?

...komplette Frage anzeigen

2 Antworten

Wenn die Daten nicht sortiert sind nach Datum und anschließend nach Empfänger wird das schwer.

Sollten die Daten sortierbar sein, dann geht das mit einer einfachen Wenn-Formel

=WENN(UND(B3=B2;J3=J2);0;1)
Antwort bewerten Vielen Dank für Deine Bewertung
Jackie251 08.12.2015, 08:45

das funktioniert nicht korrekt, hier erhält das letzte Paket die 1 nicht das erste

0
Sawascwoolf 08.12.2015, 08:53
@Jackie251

Das kommt ja auf die Sortierung an...  Achso, die Formel gehört natürlich in Zeile 3, hatte ich vergessen zu erwähnen.

1

das kannst du hiermit erreichen

=(ZÄHLENWENNS($B$2:B2;B2;$J$2:J2;J2)=1)*1
Antwort bewerten Vielen Dank für Deine Bewertung
Sawascwoolf 08.12.2015, 08:57

Geniale Formel :D Den Bereich durch die $ oben festzuhalten und somit dynamisch zu erweitern... auf die Idee bin ich bisher noch nicht gekommen


Allerdings stimmt das so nicht ganz, es können ja auch mal 5 Pakete am gleichen Tag zum gleichen Empfänger geschickt werden.

0
Jackie251 08.12.2015, 09:06
@Sawascwoolf

Bei 5 Paketen an einem Tag erfüllt auch nur das erste die Bedingung, da es naja eben die erste Kombination von Tag + Empfänger ist.
Und nur wenn im Zählbereich genau einmal die Kombination auftritt gibts eine 1.
Beim 2. Paket findet Zählewenns schon 2 Möglichkeiten - daher fällt der Check "=1" negativ aus und es gibt eine 0

2
Sawascwoolf 08.12.2015, 12:09
@Jackie251

Ah, ich hätte die Formel in Zeile 3 geschrieben^^ - da hätte sie aber keinen Sinn ergeben^^

0
Oubyi 08.12.2015, 12:05

DH!
Da ich ZÄHLENWENNS nicht so mag und lieber mit Wahrheitswerten arbeite, hätte ich es so gelöst:
=(SUMMENPRODUKT(($B$2:B2=B2)*($J$2:J2=J2))=1)*1
Aber natürlich sind beide Lösungen gleichwertig.

2
Jackie251 08.12.2015, 12:08
@Oubyi

Ich mag Summenprodukt nicht, weils es eigentlich Produktsumme heißen müsste ;-D

1

Was möchtest Du wissen?