Hallo zusammen, wenn ich in Excel auf der linken Seite eine Spalte habe und über der Tabelle eine Zeile. Kann ich diese mit einander abgleichen?

5 Antworten

Warum schrreibt hier NIEMAND die realen Adressen hin??? Ätzend!

So kannst Du das finden.

Die Funktion heißt zB (Lage der Tabelle B2:K20, Überschriften in Sp.B und Zeile 2) (irgendwo)

=Index(B2:K20;Vergleich("Bauteil";B2:B20;0);Vergleich("Anlage";B2:K2;0))

anstatt des Textes von Bauteil kannst du auch den Bezug auf das Bauteil setzen, gleiches gilt für den Text von Anlage)

markieren: Wo bzw in welchem Zusammenhang soll das erkannt werden? Als EIN Bestandteil von einem Text, zB "Eingang von 5 "Bauteil" für "Anlage"? Vorausgesetzt, dass der Plural von Bauteile "Bauteil" enthält (zB "Manschetten" enthält "Manschette", aber "...Schlauch" ist NICHT enthalten in "...Schläuche": dann als Norm: immer Einzahl), könnte ich mir eine Lösung mit Hilfszeile + Hilfsspalte vorstellen, zB C22:K22; M3:M20: Der Eintrag soll in A1 erfolgen (ggf hinterher woanders hinschieben, neue Spalten/Zeilen für neue Anlagen/Bauteile innerhalb einfügen):

in C23: =NICHT(ISTFEHLER(FINDEN(C2;$A$1;1)))*SPALTE()

rüberziehen bis M23

in N3: =NICHT(ISTFEHLER(FINDEN(B3;$A$1;1)))*ZEILE()

runterziehen bis N20 (oder 22)

in N23: =ADRESSE(SUMME(N3:N22);SUMME(C23:M23))

in N23 ist die Adresse der sich kreuzenden Überschriften. In B3:B22 und in C2:M2 dürfen keine leeren Zellen stehen, auch sich wiederholende Wortteile (zB Nr. in Tel-Nr) müssen geändert werden (im Beispiel reicht ein Leerzeichen oder ein Punkt mehr in Nr..)

Kennzeichnung der Zellen: C3 auswählen. Bedingte Formatierung, neue Regel. Formel verwenden. Formel:

=TEXT(ZELLE("Adresse";C3);"@")=$N$23  (beachte: C3 enthält kein $ !!)  Format: nach Wahl, zB Hintergrund weitere Farben helltürkis.

Format mit dem Pinsel übertragen auf alle Zellen in C3:M22

liest sich kompliziert, aber Schritt für Schritt sollte es gehen.

Ja, das funktioniert über bedingte Formatierung, ich würde es so machen. Gibt aber sicher mehrere Möglichkeiten.


Markiere die Zeile, die farbig hervorgehoben werden soll.


Gehe auf "bedingte Formatierung" --> Neue Regel --> Formel zur Ermittlung...

Folgendes eingeben:


=SUMME(ISTZAHL(SUCHEN(Bereich_der_Suchwörter;zu_unteruschende_Zelle))*1)

Dann noch eine gewünschte Formatierung hinterlegen. Wenn du die Formatierung auf andere zeilen Kopierst, achte darauf, dass du den Bereich deR Suchwörter feststellst.

Also ich würde die Tabelle anders aufbauen, das was du beschreibst klingt etwas merkwürdig.

Eine Textsuche ist nicht so einfach umzusetzen.

Daher mein Vorschlag:

Spalte A BauteilName

Spalte B Anlage

Dann kannst du über einen Datenflter dir nur die Daten der ausgewählten Anlage anzeigen.

Was möchtest Du wissen?