hallo Zusammen, könnt Ihr mir bitte mit der Wenn Dann Schleife helfen. Die genaue Beschreibung ist im Bild (Zelle C2) beschrieben. Vielen Dank in Voraus?

... komplette Frage anzeigen

2 Antworten

=WENN(ISTFEHLER(FINDEN("GANG";GROSS(A2)));"AUTOMATIK";GROSS(TEIL(A2;FINDEN("GANG";GROSS(A2))-2;6))

Erklärung: Die Funktion versucht, das Wort "GANG" zu finden, wenn es nicht gefunden wird, gibt die Finden-Funktion einen Fehler zurück und es wird "AUTOMATIK" hingeschrieben. Wenn das Wort gefunden wird, wird ab 2 Zeichen vorher das Wort ausgeschnitten und hingeschrieben (kannst also auch 4-gang, 3-gang, 7-gang und so weiter hinschreiben). Nur wenn die Beschreibung mit dem Wort "Gang" anfängt, gibts nen Fehler.

Antwort bewerten Vielen Dank für Deine Bewertung

Beschäftige dich mal mit der WENN-Funktion in Verbindung mit der FINDEN-Funktion. Damit kannst du dir deine Lösung basteln :)

Ungefähr sowas:

WENN(ISTFEHLER(FINDEN("5-Gang";A2)>0);WENN(ISTFEHLER(FINDEN("6-Gang";A2)>0);;Automatik);"Automatik")

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?