Hallo Wer kann mir helfen, ich möchte eine Excel Tabelle erstellen in der eine Euro Betrag in in Buchstaben gewandelt wird?

... komplette Frage anzeigen

6 Antworten

Excel ist sogesehen ein umfangreicher Taschenrechner.
Die Excelprofis helfen dir sicher gern, ein mathematischen Algorythmus in Excel umzusetzen.
Diesen Algorịthmus solltest du zunächst haben. Ansonsten frage bei den Mathematiker oder geben hier soviel Informationen, dass dabei ein Sinn herauskommt.

Antwort bewerten Vielen Dank für Deine Bewertung

Das könnstet du mit der recht aufwändigen Verkettung

=WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(A2;1;"K");2;"O");3;"R");4;"T");5;"E");6;"N");7;"B");8;"A");9;"C");0;"H")

erreichen. Aufwändig weil Textfunktionen keine Arrays unterstützen

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von ReifenKoeln
05.11.2015, 11:58

Das mit den 3 Stellen stimmt, reicht mir aber für meine Anwendung, Danke für die Hilfe.

0

Leider ist mir nicht klar, was Du genau meinst. Worin besteht die Zuordnung zwischen dem Betrag und dem Text rechts?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von FGO65
05.11.2015, 11:05

1 = K
2 = O
3 = R
usw.

0

Da ich immer der Meinung bin: EXCEL kann alles, hier die Lösung (soll aber zum Weiterdenken anregen):

=SVERWEIS(GANZZAHL(A1/100);Dat;2)&SVERWEIS(GANZZAHL((A1-GANZZAHL(A1/100)*100)/10);Dat;2)&SVERWEIS(REST(A1;10);Dat;2)

Einzelheiten siehe Bild.

Gruß aus Berlin

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Jackie251
05.11.2015, 11:52

Das wird nicht funktionieren, weil es ausschließlich mit 3 Stelligen Beträgen geht

0

Ja genau so, aber ich möchte in einem Feld den Betrag z.b. 123 (Euro) eingeben, und in einem anderen Feld soll dann KOR ausgegeben werden..Der wunsch ist einen EK Preis in Buchstaben zu verschlüsseln.

Antwort bewerten Vielen Dank für Deine Bewertung

In diesem Beispiel entspricht die Ziffer 1 dem K aud dem Wort Kortenbach

KORTENBACH  hat 10 Buchstaben K=1,O=2,R=3  ..... usw Eingabe 123 gleich KOR....

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?