Hallo kann mir jemand beim Programmieren in Excel helfen?

...komplette Frage anzeigen

3 Antworten

Ich sehe auf dem ersten Blick nicht die Notwendigkeit eines Buttons...

Ich versuche dir mal etwas zu basteln...

Antwort bewerten Vielen Dank für Deine Bewertung
90aissurob 02.02.2016, 21:56

Der Button soll nur der Einfachkeit halber bzw. des Komfort dienen ;) ich habe aber ka ob man das auch ohne Button regeln kann. Mit wäre mit lieber :) aber Danke schonmal!

0
Suboptimierer 02.02.2016, 22:01

E1: =SUMME(A1:D1)
F2: =E2-E1

Beides herunterziehen.

Der einzige Unterschied zu deiner Anforderung ist, dass die Eingaben am ersten Tag in A1:D1 getätigt werden, am zweiten Tag in A2:D2 and so on.

Wenn du willst, kannst du sogar prüfen, ob A1:D1 gefüllt ist und nur in diesem Fall summieren: =WENN(A1&B1&C1&D1<>"";<Formel>;"")

0
90aissurob 02.02.2016, 22:14
@Suboptimierer

Okay vielen Dank erstmal. Soweit absolut verständlich...

Ist die Geschichte mit dem Button auch möglich, das man die Excel-Datei sozusagen nutzen kann wie ein Programm?

Ich würde gerne das man die 4 Felder ausfüllt und dann berechnen lässt. Das "Programm" müsste halt erkennen welcher Tag ist und es in das entsprechende Feld das Ergebnis schreiben... auch wenn man einen Tag auslässt. Es müsste dann halt die Differenz vom letzen berechneten Ergebnis zum aktuellen nehmen...

0
Suboptimierer 02.02.2016, 22:23
@90aissurob

Joa, das geht auch, macht es allerdings unnötig kompliziert, wie ich finde.

Das Tagesdatum kriegst du mit Date(), die letzte befüllte Zeile bekommst du mit Range("E1").End(xlDown).Offset(1,0), die Summe über .Offset(0,-4).Value + .Offset(0,-3).Value... und die Differenz zum Vorwert auf ähnlichem Weg. Wenn du willst, kannst du natürlich auch eine Schleife bauen.

Wenn das keine Übung für VBA ist, wäre es mir den Aufwand nicht wert.

1
90aissurob 02.02.2016, 23:34
@Suboptimierer

Okay ich schau mal ob ich mich da irgenwie rein fuchsen kann.... Vielen Dank für deine Hilfe!!!

0

Machst du eine Ausbildung und wenn ja wo, oder muss man das als Student beherrschen? Allgemein brauchst du ja die Excel Tabelle. 

Antwort bewerten Vielen Dank für Deine Bewertung
90aissurob 02.02.2016, 21:58

ich studiere und möchte eine Befragung damit auswerten.

0

Müsste mit der Makro Aufzeichnung zu machen sein. Google mal danach.  

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?