Hallo, ich möchte in einer Tabelle bzw. Spalte vermeiden, das zwei identische Zahlen vorkommen. Welche Formel kann ich verwenden?

...komplette Frage anzeigen

2 Antworten

Du kannst Duplikate mit bedingter Formatierung einfärben. Beispiel für Spalte A:

=ZÄHLENWENN(A:A;A1)>1

Diese Formel kannst du auch neben die Spalte A schreiben, herunterziehen und mit ODER zusammenfassen.

Duplikate löschen geht mit

Daten → Datentools → Duplikate entfernen

Antwort bewerten Vielen Dank für Deine Bewertung
kiara36 14.07.2016, 13:37

Das Problem ist aber, wenn man eine umfangreiche Tabelle hat, ist es sehr schwierig das gefärbte Feld zu finden.
Löschen wollte ich nicht, ich möchte wissen, welche Duplikate vorhanden sind um evtl. die Ursache für das "doppeln" herauszufinden.

Oder erscheint die Färbung bei zeitgleicher Eingabe?

0
Suboptimierer 14.07.2016, 13:45
@kiara36

Die Färbung erscheint bei zeitgleicher Eingabe.

________________

Wenn du die Formel neben der Suchspalte schreibst, kannst du mittels normalem Autofilter Duplikate finden.

1

A1: Daten/ Datenüberprüfung/ Zulassen: Benutzerdefiniert/ Liste:
=ZÄHLENWENN(A1:A100;A1)=1
Das musst Du allerdings für jede Zelle einzeln machen.
Zumindest wüsste ICH nicht, wie man das für mehrere Zellen gleichzeitig macht.

Alternativ per VBA.

Alternativ per Bedingte Formatierung, sodass identische Zahlen zwar nicht vermieden, aber sofort bei Eingabe farblich hervorgehoben werden.

Falls Dich die Alternativen interessieren frage nochmal nach.
Ein paar mehr Einzelheiten zu Deiner Frage wären auch nicht schlecht.

Antwort bewerten Vielen Dank für Deine Bewertung
Suboptimierer 14.07.2016, 13:49

Entweder den Bereich mit $ festsetzen oder 

=ZÄHLENWENN(A:A;A1)=1

Dann funktioniert die Prüfung auf der ganzen Spalte / auf alle markierten Zellen der Spalte A.

1
PWolff 14.07.2016, 14:01
@Suboptimierer

Die Gültigkeitsprüfung kann man durch Kopieren der Zelle auf andere Zellen übertragen - auch auf mehrere Zellen gleichzeitig, und sogar auf eine ganze Spalte:

Die Zelle mit dieser Gültigkeitsprüfung markieren

Strg+C

Die gesamte Spalte A markieren (Klick auf den Spaltentitel "A")

Strg+V

(Nachteil: die letzte verwendete Zeile der Tabelle ist dann die letzte überhaupt mögliche Zeile der Tabelle)

1
Oubyi 14.07.2016, 15:02
@PWolff

DH!
Danke.
Auf die einfachste Möglichkeit bin ich - mal wieder - nicht gekommen.
Der Bereichsbezug muss dazu nur absolut gesetzt werden:

=ZÄHLENWENN($A$1:$A$100;A1)=1

0
PWolff 14.07.2016, 15:26
@Oubyi

Ich hab beim Testen Suboptimierers Vorschlag genommen:

=ZÄHLENWENN(A:A;A1)=1
1

Was möchtest Du wissen?