Hallo, ich habe eine Excel Tabelle mit 31 Tagen, jeder Tag hat 96 Werte?

... komplette Frage anzeigen

4 Antworten

Welche Werte aus welcher Spalte möchtest du wiedergeben?

Den ersten Wert (im Beispiel aus Spalte C) von Tag 15 erhälst du mit

=INDEX(C:C;VERGLEICH(15;A:A;0)+ZEILE(A1)-1)

Diese Formel kopierst du nach unten, so dass sie in 96 Zeilen angezeigt wird. Dabei wird jeweils der folgende Wert aus Spalte C wiedergegeben. Statt 15 kannst du natürlich auch eine Zelle als Bezug angeben, z.B. ein Suchfeld.

(Die Formel zeigt auch Werte von anderen Tagen an, falls du sie zu weit kopierst. Falls sie dahingehend idiotensicher sein muss, wird sie komplexer)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Oubyi
10.07.2017, 14:10

DH!

1
Kommentar von Lars266
10.07.2017, 14:50

Die Formel trifft es genau.  Danke dir!!!

0

Die zugehörigen Spalten tageweise auslesen kannst Du mit der Formel:

=SUMMENPRODUKT((15+B:B=A:A+B:B)*C:C) (bzw D:D)

Das Zweite geht aber nur für Zahlen in C bzw D, auch in A und B dürfen keine Texte stehen.

die 15 kannst Du auch als $-Bezug einbringen und so mit nur einem Eintrag variieren. Und/Oder die Tageszahl des Datums nehmen, wenn das in A als Datum drinsteht.

merkwürdigerweise krieg ich diese Matrixformel nicht zum Laufen (in der dürfte in C1|D1 nichts stehen):
{=index(C:C;Wennfehler(Vergleich(15+B:B;A:A+B:B;0);1))}

Mag jetzt aber nicht mehr, SumProd funktioniert ja (getestet)

Antwort bewerten Vielen Dank für Deine Bewertung

Hallo,

wenn mich nicht alles Täuscht, warum verwendest du dann nicht den SVERWEIS()?

Da es sich ja wohl immer um die gleiche Anzahl an Spalten handelt, kannst du doch eine Spalte mit Suchbegriff und untereinander folgenden SVERWESs() Funktionen die Werte aus Spalte 2, 3, 4, 5, 6, 7 .... auslesen und anzeigen lassen.

Oder hab ich jetzt was falsch verstanden?Grüße,

iMPerFekTioN

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von DeeDee07
10.07.2017, 14:04

Wie listet man per Sverweis alle Ergebnisse auf, wenn das Suchkriterium mehrfach vorkommt? (in diesem Fall die Nummer des Tages, 96 mal)

0
Kommentar von Lars266
10.07.2017, 14:39

Im Grunde muss die Formel den Tag und die dazugehörige Zeit in der Matrix finden und den dazu gehörigen Wert ausgeben. Wie setzt man den Sverweis um?

0

Du kannst eine 1:1-Verlinkung auf deine Originalspalte machen. Jeden Wert verlinkst du über einen relativen Zellbezug.

Danach definierst du einen Autofilter auf die Verlinkung.

(ungetestet)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Lars266
10.07.2017, 13:43

Der Tag 15 kann variieren. Der Tag wird durch eine Formel bestimmt.

0

Was möchtest Du wissen?