Hallo, ich bräuchte bitte Hilfe bei der Erstellung einer Excel-Funktion mit mehreren Wenn-Bedingungen :-)?

... komplette Frage anzeigen

4 Antworten

Das könnte man zwar auch mit einer Wenn Funktion machen, aber es ist ja lediglich eine Zuordnunggeht so einfacher

=VERWEIS(A2;{0;18,5;25};{"zu niedrig";"normal";"erhöht"})

Bei dir wären 18,5 gar nicht definiert gewesen, des weiteren müssen Textargumente für Excel immer in Anführungszeichen. Und wenn man mehre Textergebnisse zusammenhängen will geht das nicht mit "+" denn dann versucht excel zu addieren und scheitert. Texte zusammenfügen geht mitttels &


Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
08.11.2015, 18:45

@Jackie: DH!

@FS: vllt noch wichtig zu erwähnen, dass Verweis eine steigend geordnete Liste braucht.

Und man kann die Formel noch erweitern (war so nicht gefragt):

=Wenn(Oder(G2>29;G2<16);"erheblich ";"")&VERWEIS(G2;{0;18,5;25};{"zu niedrig";"normal";"erhöht"})

Das ginge auch mit der Wenn-Formel.

Und um im von Jackie vorgegebenen System zu bleiben:

=VERWEIS(G2;{0;16;29};{"viel ";"";"stark "})&VERWEIS(G2;{0;18,5;25};{"zu niedrig";"normal";"erhöht"})

Die fachlichen Grenzen müsstest du selbst bestimmen.

0

Wenn du die Excel Datei hochladen könntest würde ich gerne helfen doch leider weiß ich nicht was BMI ist und kann mich nur sehr schwer in die Situation reindenken.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von JenniferM15
08.11.2015, 16:11

BMI ist der Bodymaßindex und wird berechnet mit Körpergewicht in kg/ Größe in m^2 :-)   Ja gern, wie kann ich denn hier eine Datei raufladen?

0

Z.B. so:

=WENN(G2<18,5;"zu niedrig";WENN(G2>25;"erhöht";"normal"))

Antwort bewerten Vielen Dank für Deine Bewertung

Mit  Wenn ist die Formel besser zu verstehen

=WENN(G2>=25;"Erhöht";WENN(G2>18,5;"Normal";"Zu niedrig"))

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von JenniferM15
09.11.2015, 17:33

Vielen vielen Dank euch allen, hab's jetzt geschafft! :)

0

Was möchtest Du wissen?