Ich möchte gerne das Excel mir die Zahl in Prozent ausgibt sobald 100.000$ überschritten sind?

... komplette Frage anzeigen

4 Antworten

ich weiß nicht, ob ich dich richtig verstehe: Du möchtest Gewinne <100.000 in $ ausgewiesen haben und >=100.000 in % mit 100.000=100% ?

Da kann diese Formel helfen:

=WENN((A1)/100000-1<0;(A1);TEXT((A1)/100000-1;"0,00%"))

Formatierst Du sie noch mit diesem Format (Ben-def, nicht bedingtes!):

"Gewinn: "#.##0 $;[Rot]"Gewinn: "-#.##0 $;"Gewinn: Null!";"Gewinn: "@

wird sie unverwechselbar, d.h., Du siehst sofort, wenn Du das Format versehentlich woanders hin übertragen hast und -vor allem- sie wird "sprechend"! Darüberhinaus wird die Zahl wiederverwertbar mit der Formel:

=WENN(ISTTEXT(B1);B1*100000;B1)

Da könnte es aber besser sein, gleich auf A1 zuzugreifen  (oder die Formel, die A1 ergibt). Natürlich kannst Du alle A1 ebenfalls mit so einer Formel substituieren (natürlich dann in Klammern setzen).

Frag ggf nochmal zurück!

(ich hab jetzt noch schnell € zu $ verändert und nicht mehr testen können, in meinem getesteten Original sind also € statt $ eingesetzt)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Excelnewbie1
26.04.2016, 14:43

Das sieht schon Klasse aus, ich muss allerdings gestehen... So recht weiter bringt mich das nicht...
Ich glaube ich habe das nicht richtig erklärt was ich brauche...

http://www.bilder-upload.eu/show.php?file=417654-1461675589.png

Sobald die Summe Gesamt 100.000 $ überschreitet, soll er im Prinzip rechts den Überschuss und daneben automatisch die Prozente ausgeben. Die Tabelle ist dann am Ende... also im Prinzip sollte ab da nach unten alles leer bleiben... Aber das ist eine andere Frage denke ich. Im Moment mache ich das so: =WENN(K9>1;0;E9*H9)

Ich denke das muss eine verschachtelte Bedingung sein?

0
Kommentar von dkilli
26.04.2016, 15:58

Eine interessante Lösung. Wenn man mit dem Ergebnis rechnen will, so muss die Formel etwas geändert werden. 

=WENN((A1)/100000-1<0;(A1);WERT(TEXT((A1)/100000-1;"0,00%")))

Damit braucht man die 2. Formel.nicht

Die Spalte wo die Formel steht als Prozent formatieren.

0

Überschuss: =MAX(0; Inv+Gew-Grenze)
Prozent: =Übersch*100/Grenze

Antwort bewerten Vielen Dank für Deine Bewertung

nimm ne if then schleife für die Prozentangabe und bei der überschusssumme würde ich ebenso vorgehen.

Alles Gute

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Excelnewbie1
26.04.2016, 10:45

Das mit der Schleife hatte ich mir auch überlegt, nur weiß ich nicht wie ich die Summe sie 100.000$ überschreitet errechne und in % darstelle.

0

Was möchtest Du wissen?