Große Exceltabelle wird ersetzt durch ein Eingabefenster?

...komplette Frage anzeigen

2 Antworten

Wenn ich das richtig verstanden habe kopiere einfach diese Formeln nacheinander rechts von AZ3 und zeihe sie danach nach unten.  (so weit wie du willst)

BA3=WENNFEHLER(INDEX($A$2:$AX$5000;VERGLEICH($AZ$3;$A$2:$A$5000;0)+ZEILE(A1)-1;VERGLEICH("Name";$A$1:$AX$1;0));"Gib in AZ3 einen Namen ein!")

BB3=WENNFEHLER(INDEX($A$2:$AX$5000;VERGLEICH($AZ$3;$A$2:$A$5000;0)+ZEILE(A1)-1;VERGLEICH("Vorname";$A$1:$AX$1;0));"Namen!")

BC3=WENNFEHLER(INDEX($A$2:$AX$5000;VERGLEICH($AZ$3;$A$2:$A$5000;0)+ZEILE(A1)-1;VERGLEICH("Str.";$A$1:$AX$1;0));"Namen!")

BD3=WENNFEHLER(INDEX($A$2:$AX$5000;VERGLEICH($AZ$3;$A$2:$A$5000;0)+ZEILE(A1)-1;VERGLEICH("Nr.";$A$1:$AX$1;0));"Namen!")

BE3=WENNFEHLER(INDEX($A$2:$AX$5000;VERGLEICH($AZ$3;$A$2:$A$5000;0)+ZEILE(A1)-1;VERGLEICH("PLZ";$A$1:$AX$1;0));"Namen!")

BF3=WENNFEHLER(INDEX($A$2:$AX$5000;VERGLEICH($AZ$3;$A$2:$A$5000;0)+ZEILE(A1)-1;VERGLEICH("Stadt";$A$1:$AX$1;0));"Namen!")

Falls es nicht klappt schau bitte zuerst nach ob du z.B. Str. oder Stadt anders geschrieben hast.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Freidenz
23.03.2016, 19:02

Schaus mir gleich an. Danke

0

Es gibt auch Lösungen für SVERWEIS mit mehreren Treffern, aber das erscheint arg mit Kanonen auf Spatzen geschossen zu sein.

Im Grunde kannst Du die Möglichkeiten des Autofilters nutzen: Der User wählt entweder aus der Liste aus (was zugegebenermaßen bei 5000 unübersichtlich wird) oder schreibt es eben direkt in das Suchfenster (wird gerne übersehen).

Den Filter könntest Du ggf. auch über ein Makro füllen lassen, wenn sowas unbedingt gewünscht ist. Also eine Zelle definieren, wo der Suchbegriff eingetragen wird, einen Button daneben und fertig.

Als Makro reicht im Zweifel ein einzelner Befehl: C1 ist hier die Such-Zelle

Sub Makro1()
ActiveSheet.Range("$A$2:$C$6").AutoFilter Field:=1, Criteria1:=Range("C1").Value
End Sub
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Freidenz
23.03.2016, 18:55

Wie geht das mit den Makros. Hab das noch nie versucht...

0
Kommentar von Freidenz
23.03.2016, 19:01

Ich will ja die Tabelle minimieren damit die Mitarbeiter nur das vor Augen haben was sie eben auch suchen...

0

Was möchtest Du wissen?