"Gamer"-Zahlenformat in Excel

...komplette Frage anzeigen

6 Antworten

So kompliziert ist die Formel nicht. Kommen nur Zahlen im Format 10^n vor, oder auch "krumme" Zahlen wie 3.443.725? Und falls letzteres, was soll damit gemacht werden?

Auch Krumme. Die sollen dann mit zwei Nachkommastellen angegeben werden.

0

=WENN(A1>=10^6;A1/10^6&" M";WENN(A1>=10^3;A1/10^3&" T";A1))

rechnen kannst Du damit aber erst nach "Wiederaufbereitung" ("Gamerzahl" sei in D1):

=LINKS(D1;LÄNGE(D1)-2) * WENN(RECHTS(D1;2)=" M";10^6;WENN(RECHTS(D1;2)=" T";10^3;1))

Kannst das beliebig höher verschachteln auf B (=am.Billions), T (=am.Trillions),
oder auch auf Deutsch: Tsd, Mio, Mrd...,
dann muss es bei diesen längeren Bezeichnungen natürlich Länge -4 heissen und rechts(D1;4)=" Mio", etc.
Hauptsache ist aber, die Kürzel sind alle gleich lang.

ggf noch runden:
=WENN(A1>=10^6;runden(A1/10^6;2)&" M";WENN(A1>=10^3;runden(A1/10^3)&" T";A1)) Der beim Runden weggeschnittene Rest ist allerdings unwiderruflich weg, er kann beim Wiederaufbereiten nicht mehr rekonstruiert werden. Du kannst aber das Zahlen-UrErgebnis in einer separaten Zelle "zwischenlagern" und nur für die Darstellung die .. T oder .. M -Form benutzen, dann kannst Du Dich auch in Folgerechnungen ganz ohne Wiederaufbereitung auf die noch exakte Zahl beziehen.

0

Ohne komplizierte Formeln geht das nicht. Wenn du in A1 ne Zahl schreibst, kannst du z.B. in B1 diese Formel setzen, um es in k oder M umzurechnen:

=WENN(A1<1000;A1;WENN(A1<1000000;A1/1000&"k";WENN(A1<1000000000;A1/1000000&"M")))

Wenn du Giga, Tera, Peta etc. auch noch haben willst, musst du die Formel selbst erweitern.

Ich vergaß zu erwähnen, dass es nicht immer "gerade" Zahlen sind, sonder auch mal 3.534.209

0
@derfussel89

Geht trotzdem. Dann wird halt 3,534209M angezeigt. Wenn du das kürzer haben willst, musst du es noch Runden, also z.B.

=WENN(A1<1000;A1;WENN(A1<1000000;RUNDEN(A1/1000;2) &"k";WENN(A1<1000000000;RUNDEN(A1/1000000; 2)&"M")))

0
=WENN((A1/1000000000000000)>=1;RUNDEN((A1/1000000000000000);2)&"P";WENN((A1/1000000000000)>=1;RUNDEN((A1/1000000000000);2)&"T";WENN((A1/1000000000)>=1;RUNDEN((A1/1000000000);2)&"G";WENN((A1/1000000)>=1;RUNDEN((A1/1000000);2)&"M";WENN((A1/1000)>=1;RUNDEN((A1/1000);2)&"k")))))

Grundet auf zwei Nachkommastellen

Bei der Formel gibt's nur das Problem, dass keine Zahlen < 1000 benutzt werden können.

0
@daCypher

sry vergessen...

dann hängt man halt noch den Sonst-Wert dran...

=WENN((A1/1000000000000000)>=1;RUNDEN((A1/1000000000000000);2)&"P";WENN((A1/1000000000000)>=1;RUNDEN((A1/1000000000000);2)&"T";WENN((A1/1000000000)>=1;RUNDEN((A1/1000000000);2)&"G";WENN((A1/1000000)>=1;RUNDEN((A1/1000000);2)&"M";WENN((A1/1000)>=1;RUNDEN((A1/1000);2)&"k";A1)))))
0

Geht doch! ;P

1000 = Sonderformat = #. K 10000 = Sonderformat = #. K

wird eingegeben als 1000 und 10000 und angezeigt als 1K und 10K. :)

Geht allerdings nur im 1000er-Bereich, für Millionen müsstest du dann ein Extra-Format mit M statt K machen - oder du versuchst es mit Formel über die bedingte Formatierung. :)

P.s.: Sry, meinte Format "benutzerdefiniert" nicht Sonderformat. Wobei 1 Million üblicherweise auch als 1000K usw. geschrieben wird. :)

0

Die Idee über benutzerdefiniertem Format in Verbindung mit bedingter Formatierung ist die beste Lösung (und funktioniert - man muss nur mit der kleinsten Bedingung >1000 starten)

Die Wahl, an welcher Stelle der Buchstabe stehen soll, ist dabei auch variabel:

# "K" ###,##
erzeugt ein 5 K 123,56

Weitere Schritte entsprechend.

DH!

2

1k, 1M, usw. sind keine Zahlenformate, daß sind verschiedene Darstellungen von Zahlen.

Das geht nicht mit Excel.

Mhm, Schade.

Trotzdem vielen Dank.

0

Was möchtest Du wissen?