Frage zu SVERWEIS?

... komplette Frage anzeigen

3 Antworten

Die zugehörige Tabelle kenne ich ja nicht, aber mein 1. Eindruck von deiner Formel ist, dass das "doppelt gemoppelt" ist.
Sowohl SVERWEIS als auch INDIREKT und INDEX, ist das wirklich erforderlich?
Normalerweise reicht eins von beiden, also entweder SVERWEIS oder die Kombi aus INDIREKT und INDEX.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von GeorgGermany
15.11.2015, 19:27

Hey,

die Möörderformel war kopiert ;-) ....

mittlerweile ist mir das auch so gekommen, Danke für den Tip.

=SVERWEIS(A122;'6985'!A1:E412;3;WAHR) ist auch ok.

Aber die '6985' ... also der Verweis auf das Arbeitsblatt Namens 6985 soll mit B1 beschrieben werden..... und da klemmt es.

0

Ich verstehe den Sinn der Matrixklammern in Deiner Formel nicht.
(Ich habe mich allerdings auch nicht intensiv mit dem Sinn der ganzen Formel beschäftigt, da mir das ohne Beispieltabelle schwer fällt)
Schau mal, ob sie nicht auch ohne klappt.
Dann sollte auch das funktionieren:

=SVERWEIS($A121;INDIREKT("'"&INDEX(B1;VERGLEICH(1;(ZÄHLENWENN(INDIREKT("'"&B1&"'!A:A");$A121)>0)+0;0))&"'!A:C");3;0)

Oder?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von GeorgGermany
15.11.2015, 19:29

Hallo, nee...das hat leider #NV zur Folge. 

0

Ich würde den Namensmanager für diese zelle nutzen und dann dort einfügen.


Vielleicht kann man das so dann umgehen. Konnte es jetzt aber nicht ausprobieren...

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?