Frage über eine Excel Formel?

...komplette Frage anzeigen

3 Antworten

Wenn in A deine Mitarbeiter stehen und in B derselben Zeile die Termine als T, T  gelistet sind

(habe ich das richtig verstanden: ggf mehrere in einer einzigen Zelle, die ausgewertet werden soll? und was ist, wenn genau 2 T vermerkt sind? das ist weder <2 noch >2!),

dann für den Mitarbeiter in A2 die Formel in :

C2: =Wenn(Länge(B2)-Länge(wechseln(B2;"T";"")<2;"X";"")

Wechseln unterscheidet Groß/klein und erzeugt keinen Fehler, wenn gar kein T vorhanden.

Auch andersrum möglich; Wenn(.......>=2;"";"X")

Steht dagegen jedes T in einer eigenen Zelle, zB im Bereich B:M, dann gibt es dafür in

N2: =Wenn(Zählenwenn(B2:M2;"T")>=2;"";"X")

Zählenwenn gibt so nur ganze Zellinhalte wieder und unterscheidet nicht Groß/klein !

Wenn also in einer Zelle Termin oder TT steht, wird das nicht gezählt, dagegen t alleine schon.

Mit umständlicheren Kunstgriffen kann man auch kompliziertere Einträge wunschgemäß auswerten.

Leider wird der Aufbau der Tabelle nicht ganz klar.
Aber mal angenommen die Namen stehen in B1:H1
Und im Bereich A3:A33 stehen die Datümer.
In B3:H33 werden die T eingetragen.
(klassische Kreuztabelle).
Dann in B2 diese Formel und nach rechts kopieren:

=WENN(ZÄHLENWENN(B3:B15;"T")<=2;"X";"")

Schau mal, ob Du das anpassen kannst. Sonst beschreibe den Aufbau Deiner Tabelle, so wie ich es getan habe, dann helfe ich Dir.
Ein Screenshot wäre eine Alternative.

DerSirius 20.05.2017, 22:49

Guten Tag,

vielen Dank für deine Antwort. Ich habe den Vorschlag mit Excel ausprobiert und leider hat die Funktion nicht ganz funktioniert. Überall ist einfach nur ein X erschienen obwohl mehr als 2 T's angegeben wurden. Ich würde mich über eine Rat sehr freuen.

Vielen Dank

Mit freundlichen Grüßen

0
Oubyi 21.05.2017, 11:50
@DerSirius

Sonst beschreibe den Aufbau Deiner Tabelle, so wie ich es getan habe, dann helfe ich Dir.
Ein Screenshot wäre eine Alternative.

0

Was möchtest Du wissen?