Formel Problem bei Excel

...komplette Frage anzeigen

5 Antworten

Wenn die Datümer keine Texte sind (und in Spalte G wie Geburtstag stehen), bekommst Du die Zahl zB. der Jahrgänge 1930..1939 mit:

=Zählenwenn(G:G;"<1.1.1940")-Zählenwenn(G:G;"<1.1.1930")

ich war selber überrascht, wie einfach das inzwischen geht!
Das war früher umständlicher:
=Zählenwenn(G:G;"<"&Datwert("1.1.1940"))-Zählenwenn(G:G;"<"&Datwert("1.1.1940"))

Bei Labeln musst Du eine Hilfsspalte anlegen mit Datumszelle*1

Iamiam 07.02.2015, 19:49

Ergänzung:
Oubyis Formel funktioniert für eine Jahresspanne sehr gut, für andere Zeiträume so nicht!
Mit der Zählenwenn-Formel kannst Du auch krumme Zeitabschnitte auswerten!

0
Iamiam 07.02.2015, 20:46
@Iamiam

...Kriterium, das ja auf die Zelle verweist:
Das geht Syntax-mäßig etwas anders:

Ältere Grenzzeit (ab, seit) 1.1.1930 in H1
Neuere Grenzzeit (bis 1 Tag vor) 1.1.1940 in H2

=Zählenwenn(G:G;"<0"&H2*1)-Zählenwenn(G:G;"<"&H1*1)

Das *1 schadet bei Zahlen nichts, würde aber Labels ins Zahlendatum umwandeln.
Du könntest auch +0, -0, /1 schreiben, Hauptsache, eine neutrale Rechenoperation!

0
Iamiam 07.02.2015, 20:54
@Iamiam

Schreibfehler:

"<0" muss einfach heissen: "<"
also nochmal zum kopieren:

=Zählenwenn(G:G;"<"&H2*1)-Zählenwenn(G:G;"<"&H1*1)

0
Oubyi 08.02.2015, 15:02
ich war selber überrascht, wie einfach das inzwischen geht!

DH!
Bin ich auch ㋛

0

Jetzt möchte ich wissen, wie viele im Jahr z. B. 1975 geboren wurden.

Angenommen die Datümer stehen in Spalte B, dann sollte diese Formel klappen:

=SUMMENPRODUKT((JAHR(B1:B1000)=1975)*1)

Klappt es?

KleineGottOhm 08.02.2015, 11:16

Nein Leider nicht. Es rechnet mir immer 4 aus. Aber Danke

0
Oubyi 08.02.2015, 14:59
@KleineGottOhm
Es rechnet mir immer 4 aus.

DAS kann ich mir nur so erklären, dass es tatsächlich auch 4 sind!
Kann es sein, dass die Datümer, die Deiner Meinung nach nicht gezählt werden, nicht richtig als Datum eingegeben wurden?
Suche Dir mal fünf Zellen 'raus, die Deiner Meinung nach gezählt werden sollten und gib in einer Nachbarzelle dann ein:
=JAHR(B20)
(falls es um die Zelle B20 geht, sonst anpassen).
Die Zellen, bei denen die Formel NICHT 1975 ergibt, sind dann nicht richtig eingegeben.
Wenn Du nicht weißt warum, kopiere mal ein Beispiel hier ein.
Hilft Dir das weiter?
Sonst wäre es am besten, wenn Du eine Beispieldatei bei einem Upload-Service (z.B. http://www.file-upload.net) hochladen und hier den Link einstellen könntest. Oder Du zeigst zumindest hier (in einer neuen Antwort) einen Screenshots.

0

Man kann sein Hirn auch mit Excel vergewaltigen ... ;-) ...

Ich hätte 3 Spalten verwendet für Tag / Monat / Jahr und anschließend einen Filter bei der entsprechenden Spalte für das gewünschte Jahr gesetzt ...

Iamiam 07.02.2015, 19:04

Kann man machen, wird abetr sehr umständlich mit den Auswerteformeln.

0
KleineGottOhm 08.02.2015, 11:13
@Iamiam

DAnke Alex. Das mit dem Filter hab ich auch gemacht. Dann "deaktiviere" die Jahrgänge die ich nicht brauche und muss ja dennoch quasi Häöändig zählen und eintragen. Ich müsste dann aber auch jedes Mal eine Korrektur vornehmen wenn ein Jahrgang wegfällt und einer hinzu käme.

Wennich das jetzt richtig verstehe wie du das meinst... Dennoch Danke

0
Alex313 08.02.2015, 11:37
@KleineGottOhm

Beschreibe doch mal in kurzen Sätzen, was Du mit dieser Tabelle anfangen möchtest bzw. welche(n) Nutzen sie für Dich haben soll. Auch brauchst Du nicht die nichtgewollten Jahrgänge zu deaktivieren, sondern die gewollten zu aktivieren.

Die Häufigkeit muss acu nicht gezählt werden. Die Anzahl der gefundenen Datensätze wird bei Excel links unten angezeigt.

Wenn ein Jahrgang hinzukommen oder wegfallen sollte, musst Du eh neue Datensätze erfassen bzw. löschen. Da hilft Dir dann auch die "WENN" Funktion nicht wirklich weiter.

Grundsätzlich stelle ich mir zuerst immer die Frage nach dem "Aufwand und Nutzen, im Kontext zum Anwendungsbereich".

Je nach Anwendungsbereich, kann ich die Datensätze ggf. auf ein anderes Tabellenblatt (in eine andere Tabelle) kopieren und weiter aufbereiten.

Zudem ist Excel in erster Linie ein Programm für "Tabellenkalulation(en)". Daher würde ich für den vermuteten Anwendungsbereich "Access" empfehlen.

0
Alex313 08.02.2015, 11:49
@Alex313

P.S.

Wenn Du bei der Auswahl des Filters wechselweise auf "Alle" klickst, dann werden wechselweise "Alle" oder "Keine" angezeigt. Je nach Zweckmäßigkeit, kannst Du dann einzelne Kriterien auswählen oder abwählen ...

0

Wenn du dir das Jahr aus dem Datum in eine Hilfsspalte extrahierst (mit Jahr(zelle)), dann könntest du es so lösen:

=ZÄHLENWENN(B1:B3;"=1978")

(im Bereich b1:b3 nach dem Jahrgang 1978 suchen.)

Ortogonn 07.02.2015, 21:17

An sich richtig, du könntest die Formel aus der Hilfsspalte aber auch gleich in deine Zählenwenn-Formel einbauen.

0

Ich Danke euch für eure Hilfe. Echt toll wie schnell das hier geht...Hut ab! Aber leider funktioniert keine eurer Lösungen. Bei Excel sspielt man ja so lange bis man die richtige Antwort hat, vorrausgesetzt man kennt die Formel oder hat ne Ahnung wie sie aufgebaut sein müsste. So mach ich das oft aber da zermater ich mir das Hirn.

Ich werde da mal weiter versuchen müssen...

Aber DANKE nochmal

schmiddi1967 10.02.2015, 07:58

Habe das ganze jetzt erst gelesen, besteht dein Problem noch?

0

Was möchtest Du wissen?