Formel in Excel will nicht so wie ich es will?

... komplette Frage anzeigen

7 Antworten

Dazu musst du mehrere Wenn-Befehle verschachteln.

=Wenn(Summe<10;5;Wenn(Summe<20;4;Wenn(Summe<30;3;2)))

Du hast allerdings nicht definiert, was bei Summe=20 etc. sein soll. So wie ich es geschrieben habe, werden dann 3 Punkte vergeben.

Antwort bewerten Vielen Dank für Deine Bewertung

Das geht folgendermaßen für eine Summe in A1:

=WENN(A1<10; 5; WENN(UND(A1>10( A1<20); 4; WENN(UND(A1>20; A1<30); 3; WENN(A1>30; 2; 0))))

Zu beachten sind hierbei die Werte kleiner 0, sowie 10, 20 und 30. Bei diesen Werte erscheint der Wert 0 in der Zielzelle. Sollen die gewählten Intervallgrenzen inklusiv sein, so muss "<" in "<=" bzw. ">" in ">=" geändert werden. ;)

Ich hoffe, ich konnte dir helfen; wenn du noch Fragen hast, kommentiere einfach. 

LG Willibergi 

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
30.07.2016, 23:14

intendiert ist  vermutlich das:
=Wenn(Sum<=10;5;wenn(Sum<=20;4;wenn(Sum<30;3;2)))

Zu den Grenzwerten selbst wurde nichts gesagt, könnte auch sein:

=Wenn(Sum<10;5;wenn(Sum=10;4,5;wenn(Sum<20;4;wenn(sum=20;3,5;wenn(Sum<30;3;wenn(sum=30;2,5;2))))))

Das ergibt für die Grenzwerte jeweils einen halben Zwischenpunkt.
Es kommt bei solchen Formeln darauf an, den unnötigen Ballast (...aber größer als 10...) wegzulassen, wenn er implizit schon in den anderen Bedingungen enthalten ist (Nicht <=10 !), also eine klar strukturierte Betrachtungsweise zu formulieren. Das muss man lange üben!

1

Du musst bei solchen Aufgabenstellungen auch angeben, was passieren soll, wenn eine Zahl genau auf einer Grenze liegt (z.B. 10 Euro: Sollen dann 5 oder 4 Punkte vergeben werden?)

Eine Lösung für positive Zahlen:

=WAHL(MIN(GANZZAHL(A1/10)+1;4);5;4;3;2)

Hier gibt es für Grenzzahlen die niedrigere Punktzahl.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
30.07.2016, 23:17

Das ist hier klar die bessere Alternative, allerdings vermutlich nicht die von der Schule gewünschte. Auch mit Verweis ginge was, das spare ich mir aber aus eben diesem Grund.

sehe grade, das hat dkilli gemacht.

0
Kommentar von gfntom
31.07.2016, 02:50

Sehr elegant!
Das Problem ist nur, wenn sich die Grenzen verschieben (z.B. von 10 auf 6, von 20 auf 22, von 30 auf 25 , usw.), dann muss diese Lösung völlig umprogramiert werden, man kann die Grenzen nicht einfach anpassen!

1

Du hast eine Definitionslücke in deiner Liste

wenn kleiner als 30 Euro dann 3 Punkte

wenn größer als 30 Euro dann 2 Punkte

und was ist bei genau 30 Euro?

Antwort bewerten Vielen Dank für Deine Bewertung

Du kannst auch diese Formel verwenden:

=VERWEIS(A1;{0;10;20;30};{5;4;3;2})

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Oubyi
30.07.2016, 21:06

DH!
Das ist die Formel MEINER Wahl!

3

=WENN(A1<10;5;WENN(A1<20;4;WENN(A1<30;3;2)))

Antwort bewerten Vielen Dank für Deine Bewertung

Hat dir eine Antwort geholfen?

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?