Formel für wenn bei Excel? ?

... komplette Frage anzeigen

2 Antworten

Diese Formel in I13 und runterkopieren:

=G13/INDEX($D$4:$D$8;VERGLEICH(F13;$C$4:$C$8;0))

Klappt es?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
21.08.2016, 17:40

Man sieht hier mal wieder, wie notwendig Leute wie Du sind, bei soviel im wahrsten Sinn des Wortes hilflosen Antworten!

2
Kommentar von areck
22.08.2016, 10:01

vielen dank für die formel, funktioniert super. jedoch habe ich das problem das in den leeren zellen darunter (wo die formel reinkopiert ist für zukünftige einträge) ein fehler gezeigt wird und somit die endsumme am schluss der tabelle nicht berechnet werden kann.

hast dafür auch noch eine lösung, wäre dir sehr dankbar!

0

Hallo,

bei deinem Beispiel war folgender Fehler "wenn f13 USD dann g13/d6"

Dies wäre meine Lösung:

=WENN(F13="";"";WENN(F13=$C$4;G13/$D$4;WENN(F13=$C$5;G13/$D$5;WENN(F13=$C$6;G13/$D$6;WENN(F13=$C$7;G13/$D$7;WENN(F13=$C$8;G13/$D$8;""))))))

Formel zusammenhängend schreiben oder Formeltext markieren und in deiner Tabelle, beginnend in Zeile 13 einfügen und nach unten kopieren.

(Durch die 1. "WENN" Abfrage erscheint #DIV/0! nicht mehr !)

oder so:

=WENN(F13="";"";WENN(F13="EUR";G13/$D$4;WENN(F13="USD";G13/$D$5;WENN(F13="LAK";G13/$D$6;WENN(F13="NIO";G13/$D$7;WENN(F13="PGK";G13/$D$8;"")))))

Gruß Tron

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?