Formel Frage zu Summewenns mit Datumsbezug?

...komplette Frage anzeigen

2 Antworten

Wegen des Jahres wird das mit SUMMEWENNS schwierig werden.
Ich schreibe so etwas aber auch sowieso lieber mit SUMMEMPRODUKT, weil das imho immer übersichtlicher ist:

=SUMMENPRODUKT((Tabelle1!A1:A1000="DJSA Bronze")*(JAHR(Tabelle1!B1:B1000)=2009)*(Tabelle1!C1:C1000))

In Spalte B darf kein Text stehen.
Statt DJSA Bronze kannst Du natürlich auch eine Zelladresse einfügen, in der die Bezeichnung steht.
Wenn Du die Formel runterkopieren willst, dann müssen die Bezüge natürlich absolut gesetzt werden:

=SUMMENPRODUKT((Tabelle1!$A$1:$A$1000="DJSA Bronze")*(JAHR(Tabelle1!$B$1:$B$1000)=2009)*(Tabelle1!$C$1:$C$1000))

Klappt es?

P.S.: Ich sehe gerade PWolff hat das Problem mit dem Jahr in SUMMEWENNS mit zwei Bedingungen gelöst.
Ist natürlich auch nicht schlecht (DH!) und klappt.

Ghanasoccer 01.07.2017, 18:13

Ich finde es schade, dass man soetwas nicht mit Namensvergaben lösen kann. Schade

0
MGfrage1409 01.07.2017, 21:07

Leider zeigte exel mir immer wieder #Wert an
Die andere Formel hat funktioniert 😊

0
Oubyi 01.07.2017, 23:03
@MGfrage1409

Wenn die andere funktioniert ist ja alles gut.
Dass #Wert angezeigt wird, könnte daran liegen, dass in dem Bereich der Spalte B irgendwo ein Text steht:

In Spalte B darf kein Text stehen.

Aber wenn es anders klappt, ist da kein Thema mehr für Dich.

0

=SUMMEWENNS(C:C;A:A;"DJSA";B:B;">=01.01.2009";B:B;"<01.01.2010")

Oubyi 01.07.2017, 17:22

DH!

0
MGfrage1409 01.07.2017, 21:06

Vielen Dank !
Hat super funktioniert

0

Was möchtest Du wissen?