Felder erst zählen wenn gefüllt in Excel?

5 Antworten

zum Zählen von Einträgen gibts die Formel

=Anzahl2(Bereich) (Anzahl ohne2 zählt nur Zahleneinträge)

Die zurückgegebene Zahl kannst Du in Bereich.verschieben oder in =indirekt(Adresse(Startzeile+Ahnzahl2()-1;Spalte))

oder auch in index/Vergleich verwenden. Da ich Dein WO und WIE nicht kenne, kann ich nichts weiter dazu sagen.

Hm... mit ner WENN-Formel wirst Du das kaum hinkriegen, es sei denn, sie ist für jede Woche einzeln verschachtelt.

Würde da einfach die Verweis-Lösung nehmen. Einfach ne gigantisch hohe Zahl als Suchkriterium nehmen (auf jedenfall höher als die höchste vorkommene Zahl) und dann als Bezugszellen die Spalte oder Zeile, in der Du die wöchentlichen Werte reinschreibst. Nehmen wir mal an, das wäre in Spalte B, dann hieße das:

=VERWEIS(10000;B:B)

Die Formel gibt Dir den letzten Wert in der Spalte aus. Irgendwo Dein Zielgewicht notieren und die eine von der anderen Zelle einfach abziehen.

Viele Grüße!


So wie im Screenshot wäre es natürlich denkbar. Ich dachte aber eher daran, das der Wert in nur einer Zelle steht und sich jede Woche neu verändert, je nach Gewicht.

Also cih tracke jede Woche udn schreibe den Wert explizit pro Woche auf. Startgewicht und Zielgewicht sind definiert. Nun habe ich eine Zelle: Bereits abgenommen. Und eine Zelle: Noch verbleibende Kilogramm. Die zwei Zellen sollen sich jede Woche dann eben anpassen.

Bsp. ich möchte 20kg abnehmen. Ich wiege heute Startgewicht 80kg udn nächste Woche 75kg.
 Die Zelle bereits abgenommen wechselt von 0kg auf 5kg. Zelle verbleibende Kilos von 20kg auf 15kg.

Nehme ich in der folgenden Woche 2kg ab, ändert sich die Zelle bereits abgenommen in 7kg und die noch verbleibenden Kilos in 13kg.

Hoffe ihr versteht was ich vorhabe :)

Wenn Du also eine Liste anlegst, mit den wöchentlichen Wiegeergebnissen (Annahme: Spalte A = Datum, Spalte B = Gewicht) kannst Du das aktuellste Gewicht so ermitteln:
=SVERWEIS(MAX(A1:A20);A1:B20;2;FALSCH)

Damit kannst Du dann auch rechnen:
Bereits abgenommen: =80-SVERWEIS(MAX(A1:A20);A1:B20;2;FALSCH)
Verbleibende KG bis Ziel: =SVERWEIS(MAX(A1:A20);A1:B20;2;FALSCH)-60

0
@Ninombre

wie immer kommen die Erkenntnisse nach dem Abschicken... wenn ich das "Felder erst zählen wenn gefüllt" richtig deute, hast Du vermutlich die Datumswerte schon drin stehen und willst nur das Gewicht jeweils zum Datum ergänzen. Dann dürfen nicht Datumswerte noch nicht berücksichtigt werden, die noch nicht erreicht sind, also größer heute sind.

Zwei Möglichkeiten:
Auf das Datum abfragen, d.h. ob es in der Vergangenheit liegt:
=SVERWEIS(MAX(WENN(A1:A20<HEUTE();A1:A20));A1:B20;2;FALSCH)

Das aktuellste Datum ermitteln, zu dem die Zeile Gewicht gefüllt ist:
=SVERWEIS(MAX(WENN(B1:B20<>"";A1:A20));A1:B20;2;FALSCH)

Das sind beides Matrixformeln, d.h. nach der Eingabe die Zelle nicht einfach verlassen, sondern die Formel mit STRG+SHIFT+Enter abschließen, das erzeugt dann noch {} um die Formel. Machst Du das nicht, kommt eine Fehlermeldung wie #Wert.

Edit: Wie üblich, nach den umständlichen Formeln noch die einfache Lösung als dritte Option, wenn über die Sortierung sicher gewährleistet ist, dass der letzte Wert der aktuelle ist:
=VERWEIS(2;1/(B:B<>"");B:B)

http://www.office-loesung.de/ftopic492839_0_0_asc.php

0

Wenn Formel Excel mit 3 Bezügen?

Hallo zusammen, ich habe eine Frage an alle Excel-Kenner. Ich möchte für ein Turnier folgendes tabellarisch erfassen. Es gibt für einen Sieg 3 Punkte, für eine Niederlage 0 und für ein unentschieden 1 Punkt. Ich möchte dann in einem Feld die 3, 1 oder 0 Punkte anzeigen. Dieses FEld bezieht sich auf das Ergebnis. Also so: =WENN(U5>U4;"3";WENN(U5<U4;"0")) Da fehlt mir nun aber noch das unentschieden. Ich bekomme das 3. Wenn nicht hin. Wie geht das? Kann mir da jemand helfen?

...zur Frage

Sind die mir von Parship in Rechnung gestellten Kosten rechtens?

Hallo,

ich habe mich am 31.10.2015 mich bei Parship angemeldet sowie eine Premium-Mitgliedschaft für 12 Monate angeschlossen. Allerdings habe ich mich im Vorfeld in den AGB von Parship erkundigt. Dort steht geschrieben, dass ich innerhalb von 14 Tagen ohne Angaben von Gründen die Mitgliedschaft beenden kann und mir das gezahlte Entgelt zurück erstattet wird.

Nun habe ich die Kündigung am 01.11.2015 eingereicht mit einer Eingangsbestätigung am selben Tag.

Am 04.11.2015 bekam ich von Parship die Kündigungsbestätigung mit einer Zahlungsaufforderung:

Diese habe ich mal 1:1 kopiert:

Ich bedaure Ihre Entscheidung, PARSHIP nicht länger nutzen zu wollen. Ihren Widerruf habe ich erhalten und wirksam eingetragen. Im Rahmen Ihrer Premium-Mitgliedschaft garantieren wir Ihnen eine bestimmte Anzahl an Kontakten. Diese Kontakte sind gemäß der von Ihnen bei der Bestellung akzeptierten Widerrufsbelehrung und den darin enthaltenen Regelungen zum Wertersatz zu erstatten. Wir berechnen Ihnen also folgenden Wertersatz:

Ihr Produktpreis: 454,86 EUR (ohne eventuelle Aufschläge für Teilzahlungen) Laufzeit Ihres Produkts (Monate): 12 Laufzeitbezogene garantierte Kontakte: 7 Davon zustande gekommene Kontakte: 17 Bereits von Ihnen gezahlt: 37,92 EUR Wertersatz: 341,15 EUR Verbleibende Forderung: 303,23 EUR

Den Einzug der verbleibenden Forderung haben wir veranlasst. Ein Widerruf bedeutet nicht automatisch die Löschung Ihres Profils: Als kostenfreies Mitglied können Sie einige unserer Services weiterhin nutzen. Wenn Sie Ihr Profil dauerhaft löschen möchten, lassen Sie es mich bitte wissen. Ich möchte Sie jedoch darauf aufmerksam machen, dass eine Löschung nicht rückgängig gemacht werden kann! Ich würde mich freuen, wenn Sie es sich überlegen und sich erneut für eine Premium-Mitgliedschaft entscheiden. Bei weiteren Fragen wenden Sie sich gerne an meine Kollegen und mich.

WAS haltet Ihr davon und wie schätzt ihr das ein?

...zur Frage

Kann man bei Exel automatisch auf eine bestimmtes Feld des vorherigen Tabellenblatts zugreifen ohne es direkt zu benennnen?

Ich brauche eine Formel für den Dienstplan. Ich kopiere immer die letzte Woche, gebe ihr eine neues Datum und ändere die Dienstzeiten. Aber der Stundenübertrag bezieht sich dann immernoch auf die falsche Woche. Ich brauche also zum Übertragen der +/-Stunden der Vorwoche eine Formel für "Ich bin das gleiche Feld wie A17 in der vorherigen Tabelle (Woche)" also nicht "Ich bin das gleiche Feld wie A17 in Woche A" sondern eine Formel, die einfach auf ein bestimmtes Feld der vorherigen Tabelle (Woche) zugreift, auch nachdem man die Tabelle ausgetauscht hat, damit ich nicht mehr jede Woche 20x manuell eingeben muss, dass er nun nicht mehr auf Woche A zurückgreift sondern auf Woche B.

...zur Frage

Was möchtest Du wissen?