Felder erst zählen wenn gefüllt in Excel?

... komplette Frage anzeigen

5 Antworten

zum Zählen von Einträgen gibts die Formel

=Anzahl2(Bereich) (Anzahl ohne2 zählt nur Zahleneinträge)

Die zurückgegebene Zahl kannst Du in Bereich.verschieben oder in =indirekt(Adresse(Startzeile+Ahnzahl2()-1;Spalte))

oder auch in index/Vergleich verwenden. Da ich Dein WO und WIE nicht kenne, kann ich nichts weiter dazu sagen.

Antwort bewerten Vielen Dank für Deine Bewertung

So wie im Screenshot wäre es natürlich denkbar. Ich dachte aber eher daran, das der Wert in nur einer Zelle steht und sich jede Woche neu verändert, je nach Gewicht.

Also cih tracke jede Woche udn schreibe den Wert explizit pro Woche auf. Startgewicht und Zielgewicht sind definiert. Nun habe ich eine Zelle: Bereits abgenommen. Und eine Zelle: Noch verbleibende Kilogramm. Die zwei Zellen sollen sich jede Woche dann eben anpassen.

Bsp. ich möchte 20kg abnehmen. Ich wiege heute Startgewicht 80kg udn nächste Woche 75kg.
 Die Zelle bereits abgenommen wechselt von 0kg auf 5kg. Zelle verbleibende Kilos von 20kg auf 15kg.

Nehme ich in der folgenden Woche 2kg ab, ändert sich die Zelle bereits abgenommen in 7kg und die noch verbleibenden Kilos in 13kg.

Hoffe ihr versteht was ich vorhabe :)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Ninombre
08.08.2016, 17:42

Wenn Du also eine Liste anlegst, mit den wöchentlichen Wiegeergebnissen (Annahme: Spalte A = Datum, Spalte B = Gewicht) kannst Du das aktuellste Gewicht so ermitteln:
=SVERWEIS(MAX(A1:A20);A1:B20;2;FALSCH)

Damit kannst Du dann auch rechnen:
Bereits abgenommen: =80-SVERWEIS(MAX(A1:A20);A1:B20;2;FALSCH)
Verbleibende KG bis Ziel: =SVERWEIS(MAX(A1:A20);A1:B20;2;FALSCH)-60

0

Kannst du mal die Tabelle aufschreiben, so wie sie sein soll?

Und vielleicht, welche Formel du verwendest?

Antwort bewerten Vielen Dank für Deine Bewertung

Normalerweise benötigst du dafür keine WENN-Formel (siehe Screenshot). Oder habe ich etwas falsch verstanden?

Antwort bewerten Vielen Dank für Deine Bewertung

Hm... mit ner WENN-Formel wirst Du das kaum hinkriegen, es sei denn, sie ist für jede Woche einzeln verschachtelt.

Würde da einfach die Verweis-Lösung nehmen. Einfach ne gigantisch hohe Zahl als Suchkriterium nehmen (auf jedenfall höher als die höchste vorkommene Zahl) und dann als Bezugszellen die Spalte oder Zeile, in der Du die wöchentlichen Werte reinschreibst. Nehmen wir mal an, das wäre in Spalte B, dann hieße das:

=VERWEIS(10000;B:B)

Die Formel gibt Dir den letzten Wert in der Spalte aus. Irgendwo Dein Zielgewicht notieren und die eine von der anderen Zelle einfach abziehen.

Viele Grüße!


Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?