Felder erst zählen wenn gefüllt in Excel?

...komplette Frage anzeigen

5 Antworten

zum Zählen von Einträgen gibts die Formel

=Anzahl2(Bereich) (Anzahl ohne2 zählt nur Zahleneinträge)

Die zurückgegebene Zahl kannst Du in Bereich.verschieben oder in =indirekt(Adresse(Startzeile+Ahnzahl2()-1;Spalte))

oder auch in index/Vergleich verwenden. Da ich Dein WO und WIE nicht kenne, kann ich nichts weiter dazu sagen.

So wie im Screenshot wäre es natürlich denkbar. Ich dachte aber eher daran, das der Wert in nur einer Zelle steht und sich jede Woche neu verändert, je nach Gewicht.

Also cih tracke jede Woche udn schreibe den Wert explizit pro Woche auf. Startgewicht und Zielgewicht sind definiert. Nun habe ich eine Zelle: Bereits abgenommen. Und eine Zelle: Noch verbleibende Kilogramm. Die zwei Zellen sollen sich jede Woche dann eben anpassen.

Bsp. ich möchte 20kg abnehmen. Ich wiege heute Startgewicht 80kg udn nächste Woche 75kg.
 Die Zelle bereits abgenommen wechselt von 0kg auf 5kg. Zelle verbleibende Kilos von 20kg auf 15kg.

Nehme ich in der folgenden Woche 2kg ab, ändert sich die Zelle bereits abgenommen in 7kg und die noch verbleibenden Kilos in 13kg.

Hoffe ihr versteht was ich vorhabe :)

Ninombre 08.08.2016, 17:42

Wenn Du also eine Liste anlegst, mit den wöchentlichen Wiegeergebnissen (Annahme: Spalte A = Datum, Spalte B = Gewicht) kannst Du das aktuellste Gewicht so ermitteln:
=SVERWEIS(MAX(A1:A20);A1:B20;2;FALSCH)

Damit kannst Du dann auch rechnen:
Bereits abgenommen: =80-SVERWEIS(MAX(A1:A20);A1:B20;2;FALSCH)
Verbleibende KG bis Ziel: =SVERWEIS(MAX(A1:A20);A1:B20;2;FALSCH)-60

0
Ninombre 08.08.2016, 18:04
@Ninombre

wie immer kommen die Erkenntnisse nach dem Abschicken... wenn ich das "Felder erst zählen wenn gefüllt" richtig deute, hast Du vermutlich die Datumswerte schon drin stehen und willst nur das Gewicht jeweils zum Datum ergänzen. Dann dürfen nicht Datumswerte noch nicht berücksichtigt werden, die noch nicht erreicht sind, also größer heute sind.

Zwei Möglichkeiten:
Auf das Datum abfragen, d.h. ob es in der Vergangenheit liegt:
=SVERWEIS(MAX(WENN(A1:A20<HEUTE();A1:A20));A1:B20;2;FALSCH)

Das aktuellste Datum ermitteln, zu dem die Zeile Gewicht gefüllt ist:
=SVERWEIS(MAX(WENN(B1:B20<>"";A1:A20));A1:B20;2;FALSCH)

Das sind beides Matrixformeln, d.h. nach der Eingabe die Zelle nicht einfach verlassen, sondern die Formel mit STRG+SHIFT+Enter abschließen, das erzeugt dann noch {} um die Formel. Machst Du das nicht, kommt eine Fehlermeldung wie #Wert.

Edit: Wie üblich, nach den umständlichen Formeln noch die einfache Lösung als dritte Option, wenn über die Sortierung sicher gewährleistet ist, dass der letzte Wert der aktuelle ist:
=VERWEIS(2;1/(B:B<>"");B:B)

http://www.office-loesung.de/ftopic492839_0_0_asc.php

0

Kannst du mal die Tabelle aufschreiben, so wie sie sein soll?

Und vielleicht, welche Formel du verwendest?

Normalerweise benötigst du dafür keine WENN-Formel (siehe Screenshot). Oder habe ich etwas falsch verstanden?

Abnehmplan - (Excel, WENN-Formel)

Hm... mit ner WENN-Formel wirst Du das kaum hinkriegen, es sei denn, sie ist für jede Woche einzeln verschachtelt.

Würde da einfach die Verweis-Lösung nehmen. Einfach ne gigantisch hohe Zahl als Suchkriterium nehmen (auf jedenfall höher als die höchste vorkommene Zahl) und dann als Bezugszellen die Spalte oder Zeile, in der Du die wöchentlichen Werte reinschreibst. Nehmen wir mal an, das wäre in Spalte B, dann hieße das:

=VERWEIS(10000;B:B)

Die Formel gibt Dir den letzten Wert in der Spalte aus. Irgendwo Dein Zielgewicht notieren und die eine von der anderen Zelle einfach abziehen.

Viele Grüße!


Was möchtest Du wissen?