Excel-Formel bei Profis: Wie verändere ich den Inhalt eines Zellbereichs in Abhängigkeit eines Zellwerts?

... komplette Frage anzeigen

4 Antworten

Ich an Deiner Stelle würde einfach die beiden verschiedenen Formeln, die Du aus externen Tabellen holen willst, direkt in den Bereich A5:C7 schreiben und durch eine WENN-Abfrage entscheiden, welche zur Ausführung kommt.
Simples Beispiel:

A5:=WENN(A1=0;Tabelle2!A9/Tabelle2!A10;Tabelle3!A13/Tabelle3!A14)

Wenn Du Probleme hast, die beiden Formeln einzubauen, dann poste sie mal hier.

Antwort bewerten Vielen Dank für Deine Bewertung

wollen wir es mal intensivieren

Nur um ein erdachtes Rätsel zu lösen, schreib ich mir nicht die Finger wund und ist mir auch meine Zeit zu schade. Es gibt genügend Leute, die reale Probleme haben! Für Rätsel gibts eigene Foren!

im übrigen hat Oubyi einen praktikablen Vorschlag gemacht und nach dem gleichen Muster kannst Du auch die Originalformeln der Tabellen x und y platzieren, dann brauchst Du die Originaltabellen gar nicht mehr und hast keine Redundanzen!

Antwort bewerten Vielen Dank für Deine Bewertung

Man kann keine "Tabelle" in Zellen anzeigen lassen. Das geht jedoch gut mit einzelnen Zellen. 

Deshalb meine fragen:

was ist für dich "Tabelle x" und was ist "Tabelle y"? Sind beides eigene Tabellen Blätter oder nur - für dich - definierte Bereiche in einem Tabellenblatt (und sieht aus wie eine Tabelle)?

Sind beide Bereiche (x und y) gleich groß und das "Ziel" - also der Bereich wo diese Werte hin sollen - genauso groß? 

Fragen über fragen ...

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Perfekturius
12.01.2016, 11:34

Es soll keine Tabelle in eine Zelle hinein. Es soll eher ein Zellenbereich (Beispiel 9 Zellen) ausgewählt werden, wo eine ebenso große Tabelle hineinkommt. In dieser Tabelle sollen jedoch die Zellen ihre Formeln nicht verlieren, da die ausgewiesenen Zellinhalte veränderbar bleiben sollen.


Tabelle x ist gleich groß wie Tabelle y, jedoch sind die hinterlegten Formeln in den einzelnen Zellen anders.

0

Wenn ich es richtig verstehe, sollen die Formeln aus anderen Zellen quasi kopiert werden, abhängig vom Wert in A1. Formeln kannst Du ohne Makro aber nicht übernehmen.

Wenn Wert einer Zelle kannst Du natürlich übernehmen (=WENN(A1=0;G1;G10) oder was auch immer. Dann übernimmt er aber nicht die Formel, sondern das Ergebnis, dass in G1 bzw. G10 steht.

Lösung:
1. Makro
2. Die Wenn-Bedingung in die Formeln selbst einbauen, anstatt sie zu kopieren.

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?