Excel:WENN-SONST FUNKTION?

... komplette Frage anzeigen

3 Antworten

Also soviel ist einmal klar: Deine Formel stimmt hinten und vorne nicht, es steckt für mich da auch keine eineindeutige Logik drinnen.

So wie ich die Aufgabenstellung interpretiere, geht es darum, dass bei Überschreiten eines bestimmten Wertes in einer bestimmten Zelle (einer einzigen Zelle, nicht mehreren!) in einer anderen Zelle die Ziffern 1 bis 6 aufscheinen sollen:

>85% -> 1

>71% -> 2

>56% -> 3

>41% -> 4

>21% -> 5

<22% -> 6

Nehmen wir an, dass die Prozentwerte in der Zelle A1 ausgewertet werden sollen. Dann lautet die Formel:

=WENN($A$1>0,85;1;WENN($A$1>0,71;2;WENN($A$1>0,56;3;WENN($A$1>0,41;4;WENN($A$1>0,21;5;6)))))

Du musst die WENN-Bedingungen "verschachteln", "Wenn dieses eintritt; dann dieses; ansonsten (wenn dieses eintritt; dann dieses; ansonsten (wenn ....)))))

Die Formel kann in jeder x-beliebigen Zelle stehen - außer in der auszuwertenden Zelle A1.


Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Herb3472
02.12.2015, 17:26

Allgemein lautet die Formel:

=WENN(Bedingung;WAHR;FALSCH)

und mit 5-facher Verschachtelung wie in Deinem Beispiel:

=WENN(Bedingung1;WAHR;WENN(Bedingung2;WAHR;WENN(Bedinung3;WAHR;WENN(Bedingung4;WAHR;WENN(Bedinung5;WAHR;FALSCH)))))

Immer, wenn eine übergeordnete Bedingung als "FALSCH" ausgewertet wird, wird die nächste untergeordnete Bedingung ausgewertet.

1

Leider ist die Auflösung Deines Screenshots zu gering, so dass man selbst bei Vergrößerung des Bildes die Formel nicht lesen kann. Könntest Du die Formel nicht einfach hier hereinstellen?


Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von honigbaum751
02.12.2015, 16:28

ja stimmt,hier -------> =WENN(B20>0,85);"1";WENN(C17>0,71);"2";WENN(E14>0,56);"3";WENN(G11>0,41);"4";WENN(I3>0,21);"5";WENN(I4>0,21);"6" 

0

Warum schließt du die Klammer bei allen deinen WENN()-Funktionen der Formel immer schon nach der Bedingung?

Die Syntax ist

WENN ( Bedingung ; wenn Bedingung wahr, dann mach dies  ; sonst mach das  )

Du schreibst aber

WENN ( Bedingung ) ; ... ; ...

Das kann nicht funktionieren.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
02.12.2015, 17:25

Genau. entferne ALLE SCHLIEßENDEN Klammern und füge dann die gleiche Anzahl (wie die öffnenden) hinten nacheinander wieder ein.

Da Du allerdings immer wechselnde Bedingungszellen hast, nehme ich an, dass auch das keinen Sinn ergibt (wäre aber nicht auszuschließen, dass das wirklich so gemeint ist)

1

Was möchtest Du wissen?