Exceltabelle mit Namen. Unten soll eine Summe der angezeigten Namen angezeigt werden, wobei doppelte Namen aber NICHT mitgezählt werden, wie geht das?

... komplette Frage anzeigen

2 Antworten

Super, genau so wollte ich es haben. VIELEN DANK!!

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von schmiddi1967
22.10.2016, 11:12

Bitte gerne :))

1

Also in deinem Fall wäre das diese Formel wo das Ergebnis erscheinen soll, wenn deine Namen in Spalte A stehen:

=SUMME((VERGLEICH(A1:A7&"";A1:A7&"";0)=ZEILE(1:7))*1)-1

Achtung, das ist eine Matrixformel und muss mit STRG+SHIFT+ENTER abgeschlossen werden.

Sieht dann so aus:

{=SUMME((VERGLEICH(A1:A7&"";A1:A7&"";0)=ZEILE(1:7))*1)-1}


Solltest du mehr Namen haben musst du die Formel natürlich anpassen, aber bitte auf jeden Fall eine Zeile tiefer als du Namen hast oder gleich für mehr Namen festlegen.

Kommst du damit klar?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von schmiddi1967
22.10.2016, 10:21

Noch eine Möglichkeit wäre :

=SUMME(WENN(A1:A100<>"";1/ZÄHLENWENN(A1:A100;A1:A100)))

Ebenfalls eine Matrixformel aber eventuell einfacher anzupassen.

Hier wird jetzt bis A100 geprüft

2
Kommentar von Oubyi
22.10.2016, 13:07

DH!


Den Trick mit &"" um #NV zu vermeiden kannte ich noch nicht.
Merke ich mir.
Um die Vorschrift zu vermeiden, dass dann Leerzellen in dem Bereich sein müssen, kann man vielleicht so erweitern:

{=SUMME((VERGLEICH(A1:A7&"";A1:A7&"";0)=ZEILE(1:7))*1)-(ZEILEN(A1:A7)<>ANZAHL2(A1:A7))}

Oder habe ich da was übersehen?

3

Was möchtest Du wissen?