Excelrechnung nicht kleiner als 0?

...komplette Frage anzeigen

3 Antworten

Wo ist das Problem?
Wenn in D2 die Formel steht =B2-C2
und wenn C2 leer ist
dann liefert die Formel in D2 das Ergebnis: B2

Wenn B2=200 und C2 leer, dann ergibt B2-C2: 200

Falls es dir darum geht, dass du kein negatives Ergebnis in D2 haben willst, also dass 0 rauskommen soll, falls B2-C2 negativ ist, dann nimm die Formel =max(0;B2-C2)

Schau mal, ob es DAS ist, was Du willst:

=WENN(C2="";"";B2-C2)

oder:

=WENN(C2="";"-";B2-C2)

Wenn du in B2 =200 stehen hast, C2 =250 und in D2 dann =B2-C2 eingibst, wird in D2 =-50 rauskommen

Gillette95 18.01.2017, 23:55

Falls du es so meinst da du in B2 die 200 weist aber nicht weist was in C2 steht und auch nicht weist was in D2 steht wird es nicht funktionieren weil du mindestens 2 Zahlen brauchst um die 3. berechnen zu können

0
YANKOO 19.01.2017, 00:01
@Gillette95

es geht um denn fall wenn ich C2 nicht weiß, es kann auch 230 sein... das trage ich dann ein

0
Gillette95 19.01.2017, 00:03
@YANKOO

Das Feld kannst du ja solange frei lassen bis du es weist, solange stimmt dann aber D2 auch nicht.

0

Was möchtest Du wissen?