Excelformel für Zeitberechnung gesucht

...komplette Frage anzeigen Excelformel für Zeitberechnung - (Zeit, Excel, Formel)

2 Antworten

Hallo

Die große Problematik in Excel mit Minusstunden zu rechnen. Ich hatte da schon in letzer Zeit 2 Fragen mit dieser Problematik. Nachfolgend hab ich mal eine Excelbeispieldatei, wie ich mir das vorstelle. Da bräuchte man dann um diese Stunden zu summieren eine Hilfspalte. Ja wegen den Minus halt. Also schau dir die Datei mal an, ob du das so verwenden kannst. Achso und das mit dem Rot bei Minus. Das ist mit Bedingter Formatierung zu machen.

http://www.dateiupload.net/download.php?file=ce4118e802ae9f881e84b8cf484e7b26

Gruß

kann Deine Datei zwar nicht öffnen, aber die Aussage inhaltlich bestätigen:
ich hab das getrennt in die darstellenden Zellen in Sp.D und die Rechenzellen in Sp.E
Formel in D2:

=wenn(A2-B2>=0;"+"&text(A2-B2;"[hh]:mm");"-"&text(B2-A2;"[hh]:mm"))

und der Rechenformel in E2 (kann auch viel weiter rechts stehen): einfach
=WERT(A2-B2)
als Beispiel fürs Weiterrechnen in E8:
=SUMME(E2:E6)
und zur Darstellung des Guthabens als Summe in wiederum Spalte D, D8:

=WENN(E8>=0;"+"&TEXT(E8;"[hh]:mm");"-"&TEXT(-E8;"[hh]:mm"))

2

Hallo merkurus...

deine Formel funktioniert leider nicht ganz, hoffe du hast für das Problem auch noch eine Lösung. :-))

Problem ist: Wenn ich Spalte A (Ist-Zeit) eine Zeit eingebe, die kleiner ist als 23:59 wird mir ein falsches Ergebnis ausgegeben.

Beispiel: Zelle A5=8:00 Zelle B5=48:00 Zelle C5= -16:00 (mit deiner Formel) Richtiges Ergbniss wäre aber -40:00

Hoffe du kannst mir helfen bei diesem Problem.

Grüße Uwe

0
@Uwe05

Hallo

Du hast recht. Ändere mal die Formel in C5 wie folgt

=WENN(A5<B5;"-"&TEXT((B5-A5);"[hh]:mm");A5-B5)

Habe diese rechteckigen Klammer bei hh vergessen. Die Formel kannst du ja dann nach oben oder unten kopieren, damits in den anderen Zellen auch stimmt.

Gruß

1
@merkurus

COOL Super vielen Dank.... jetzt funktioniert es wie immer !!! DANKE und 5 *****

Gruß Uwe

0

Hallo...

bezüglich "Minus-Stunden" siehe meine Antwort bei:
http://www.gutefrage.net/frage/soll--iststunden-ausrechnen---excel-2012

bezüglich "rot wenn minus" siehe anliegende Bildschirmkopie (bedingte Formatierung)

Gruß aus Berlin

rot wenn minusZeit - (Zeit, Excel, Formel)

wenn Du standardmäßig die 1.1.1900-er Option verwendest, solltest Du diese (je Datei einstellbare) abweichende Option an auffälliger Stelle notieren. Ansonsten hat Dir doch Ortogonn in

www.gutefrage.net/frage/formel--formatierung

einen Lösungsweg beschrieben, Du hast ihn sogar als hilfreichste AW ausgezeichnet, was geht daran nicht? Und in den Kommentaren zu seiner vorherigen AW sind weitere Möglichkeiten genannt (ich hatte Dir die Umwandlung in Text, dann in Zahl, dann Berechnung, dann sofern das Ergebnis wieder positiv wird wieder Rückwärts zu Zeit vorgeschlagen. Wenn negative Zeiten übrigbleiben können, dann im Textformat bleiben, man kann diese UmwandlungsFormeln fast beliebig verschachteln und negative Zeitergebnisse als Text bedingt formatieren (Bedingung: wenn mit "-" anfängt, dann rote Schrift).

Funktioniert denn keine der schon vorgeschlagenen Lösungen? zu kompliziert erklärt?

2

Was möchtest Du wissen?