Excel2013 letzen passenden Wert in Liste in Matrixformel verwenden?

... komplette Frage anzeigen

2 Antworten

Ich würde die Werte nicht in Spalte A ergänzen. Das wäre in der Tat ein Erheblicher Aufwand. Ich würde mich einer Hilfsspalte bedienen, z. B. D. In D3 würde ich schreiben: =A3

In D4 dann entsprechend und herunterziehen: 

=WENN(A4="";D3;A4)

Die Formel würde ich dann auf Spalte D beziehen oder du kopierst nicht die Formeln, sondern die Werte in die Spalte A.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Jackie251
11.02.2016, 12:36

perfekt !
Danke, ich wollte die Abfrage irgendwie in die maxformel reinziehen - Hilfspalte ist natürlich viel einfacher

1

Außer der Hilfsspalten-Lösung (DH!) gibt es da noch einen Weg:
Markiere A3:A1000 (oder wie weit Diene Daten sonst reichen).
Dann F5 ("Gehe zu");
Inhalte ...;
Leerzellen;
OK;
Jetzt sind alle Leerzellen ausgewählt und A4 ist die aktive Zelle.
Schreibe jetzt (ohne die Auswahl zu ändern):
=A3  [noch kein ENTER]
Jetzt:
STRG & ENTER (gleichzeitig).
Nun sind alle Leerzellen mit den darüber liegenden Werten aufgefüllt.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Jackie251
11.02.2016, 13:39

DH !

1
Kommentar von Suboptimierer
11.02.2016, 13:45

Nicht schlecht. Das weiß nur ein echter Experte!

2
Kommentar von DeeDee07
11.02.2016, 16:20

DH! Die Frage landet wegen dieser Antwort gleich mal im Merkzettel.

1

Was möchtest Du wissen?