Excel zu grosse Tabelle

3 Antworten

Erste Zelle (mit der Formel) markieren.
Runterscrollen (mit dem Scrollbar) bis zu der Zelle, wo es enden soll.
ERST SHIFT drücken, DANN diese Zelle markieren!
Jetzt sollten alle Zellen von der ersten bis zu dieser markiert sein.
Jetzt F2 drücken.
Dann SHIFT & STRG gleichzeitig drücken und gedrückt halten, und dann ENTER!
Fertig.
Klappt es?

mit shift, Strg und Fn verhält sich LO (OO weiß ich nicht) häufig anders als xls. Wahrscheinlich aus Patentgründen notwendig. Auch ein paar andere Abweichungen sind eher ärgerlich:

zB. externe Adressen: ='file:///F:/Verz1/Datei.xls'#$Blatt.F20
Spur zum Fehler: Alt+x, v, f, die Spuren bleiben beim Speichern (+/-!),
und natürlich die Makros...

dagegen werden Wildcards zB in Zählenwenn mit vorangestelltem Punkt gebildet, zB: =ZÄHLENWENN(F2:F5;"Zä.*cards ..*ze.?.?") findet den Text
"hlenwenn ignoriert leere Zellen, vor Wildcards . (Punkt) setzen!"
Hat den Vorteil, dass man damit auch nach * und ? suchen kann.

Mit der Fkt =Unizeichen((Zeile()-1)*100+Spalte()-1) kann ich alle verfügbaren Unicodezeichen darstellen (geht in xls nicht),
hat aber auch die Eigenschaft, dass bei 50-100.000 Formeln in A1:CV~70.000die Datei recht langsam wird (der Engpass scheint die Bildschirmdarstellung zu sein) und manchmal blockiert. Aber sehr guter Wiederherstellungsmechanismus, bisher zwar einigen Ärger, aber noch keinen Verlust gehabt!

0

Wenn ich Oubyi's Vorschlag folge, erhalte ich eine Matrix-Formel, die sich nicht den Zeilen anpasst.

Soll sich die Formel anpassen, dann:

Erste Zelle (mit der Formel) markieren.  
Runterscrollen (mit dem Scrollbar) bis zu der Zelle, wo es enden soll.  
ERST SHIFT drücken, DANN diese Zelle markieren!  
Jetzt sollten alle Zellen von der ersten bis zu dieser markiert sein.  

Jetzt aber:
STRG drücken, halten und "u" drücken (STRG & u).

Nun sollte die Formel in allen Zellen, angepasst, stehen.

Ist Dir damit geholfen ?

Gruß aus Berlin

Danke für die Tipps, es hat mir aber leider nicht geholfen. Man muss die Formel markieren und dann auf das kleine, schwarze Quadrat doppelklicken, dann zieht es die Formel so weit runter, wie es links davon Werte hat.

Leider war die Datei so gross, dass das Programm mehrmals eingefroren ist und das laden jeweils ca 10 min dauerte.

0

Es gibt bei dem markierten Feld ein kleines Viereck unten rechts. Wenn man dort doppelklickt, wird die Formel bis ganz unten übernommen (vorausgesetzt, man hat links so viele Werte).

Bei mir wurde das jedoch problematisch, da das Programm jeweils abgestürzt ist. Ich habe es dann mit einer MySQL Datenbank gelöst. Ich musste sogar Indexe setzen, weil es sonst immer noch Stunden gedauert hätte...

Was möchtest Du wissen?