Excel Zeitabhängigkeit und Verfall?

2 Antworten

Ich setzte mal neu an, weil für mich das alles immer verwirrender wird.
Ich versuche das mal auf ein einfaches Szenario 'runterzubrechen mit Deinem Gutschein-Beispiel:
Du hast in A1:A100 Beträge stehen.
In B1:B100 stehen die Datümer, an denen diese "bereitgestellt" wurden.
In C1:C100 steht die Anzahl Tage, die sie gültig sein sollen (die müsstest Du ja irgendwie berechnen können).
Diese Formel zeigt Dir jetzt die Summe aller Beträge an, deren Gültigkeit heute! noch nicht abgelaufen ist:

=SUMMENPRODUKT((A1:A10)*((B1:B10+C1:C10)>HEUTE()))

Vielleicht kannst Du an diesem Beispiel einfach erklären, was nicht passt, was in Deinem Szenario also anders ist.

Mit verbundenen Augen geschossen: 

Mit SUMMEWENN kannst du als Bedingung die Zelle angeben, in der berechnet wurde, ob der Wert noch gültig ist.

vielen dank für die schnelle antwort.
okey soweit so gut. doch bin ich in der hinsicht ein noob. ist es möglich, dass du du mir kurz aufzeigst, wie ich das zu schreiben habe...mein problem liegt wiegsagt darin, dass die 180 Tage variabel sind und ich damit kein direkten Zellbezug herstellen kann oder auch kein Bereich definieren kann. oder bin ich da falsch? Wenn ja, wo hab ich meinen Denkfehler?

0
@Roach720

=SUMMEWENN(<Bereich mit Zellen, in denen die verbleibende Haltbarkeit pro Zeile berechnet wird>;">0";<benachbarte Wertespalte, über die bei Erfüllung der Kriterien summiert werden soll>)

Du kannst auch andere Rechenoperationen als nur zu summieren durchführen. Flexibler ist da die Funktion SUMMENPRODUKT.

0
@Suboptimierer

okey danke dir:)

ich stell mich wahrscheinlich einfach zu blöd an. Bzw. Ich sehe den Wald vor lauter Bäumen nicht mehr...

Ich habe keine Ahnung was du damit meinst. 

=SUMMEWENN("die Zelle, wo beschrieben wird, wie viel Tage die Gültigkeit ist";" ">0" "; "check` ich nicht")

tut mir leid:/ aber es währe wunderbar, wenn du das doch vlt. ein bisschen ausführlicher schreiben könntest.

0
@Roach720

Wie ermittelst Du denn die Frist, wenn sie in keiner Zelle direkt abgelegt ist bzw. warum machst Du das nicht so? Es muss ja eine bestimmte Berechnungslogik für die 180 Tage geben. Die könnte man irgendwo in einer Zelle hinterlegen und dann abfragen.

=SUMMEWENN(A1:A5;">"&HEUTE()-ZUFALLSBEREICH(1;180);C1:C5)

Hier steht ein Datum in A, der zu summierende Wert in C

Das fettgedruckte kannst Du durch eine konkrete Zelle oder eine sonstige Berechnungslogik ersetzen.

1
@Ninombre

Hallo Ninombre,

um genau zu sein sind es 180,18. Berechnen tue ich diese wie folgt:

Ich habe zwei Werte, einmal 0,0666 und der andere ist 12. Beides Euro-Währung. die 0,0666 gibt es am Tag, die 12,-€ ist das Gesamtergebnis. D.h. wie viel Tage werden benötigt um mit 0,0666€ 12€ voll zubekommen. Antwort: 12...Nun ist die Herausforderung:

Wenn die 0,0666 variabel sind ist auch die 180 variabel. Weiter heißt das, wenn die 12€ erreicht sind, fällt (Beispielhaft der Gutschein) der Gutschein raus und wird nicht mehr gezählt...

Somit darf er in der Tabelle nicht mehr gewertet werden. Und das möchte ich reinbringen.

Da irgendeine Hilfestellung?

Danke dir;)

0

In Excel Zellen nummerieren bis zu einem bestimmten Wert ohne Maus nach unten zu ziehen

Hallo liebe Community,

ich habe folgendes Problem und irgendwie komme ich nicht auf die Lösung oder suche nach den falschen Vokabeln.

Ich möchte Zeilen in einer Spalte fortlaufend markieren, also in B3 soll es zb. losgehen und bis zu einem bestimmten Wert gehen, der variabel ist. (der steht in einer anderen Zelle)

Wenn der Wert zb 546 ist möchte ich eine Fortlaufende Nummerierung die ab einer bestimmten Zelle bei 1 losgeht und bei 546 endet, ohne dass ich was nach unten ziehen muss. Das ganze soll quasie dynamisch sein und sich nur nach dem Wert (hier zb 546) richten.

Schon mal vorab ich suche nicht nach 1, 2,3 untereinander tippen, markieren und nach unten Ziehen.

Habt Ihr ein idee wie ich das lösen kann? gibt es dafür ein Befehl oder eine gescheite Kombination?

...zur Frage

Bitdefender verlängern?

Wenn ich noch 40 Tage Gültigkeit mit meinem alten Schlüssel habe und bereits jetzt einen neuen kaufe und aktiviere, sind die 40 Tage dann weg oder addieren die sich zu dem neuen Jahr?

...zur Frage

Kann excel muster in zahlen oder wörtern erkennen?

Gibt es eine möglichkeit das excel muster wie "HALLO" oder "12338" erkennt und sie so aus einer reihe zahlen denen zuordnet die auch aus 4 verschiedenen ziffern bestehen und die 3. und die 4. gleich sind?

...zur Frage

Datum fortlaufend eingeben für Apple Mac

Ich möchte eine Tabelle mit fortlaufendem Datum auf Excel erstellen. Leider werden bei der normalen Tastenkombination für weiterlaufendes Datum auf Mac nicht die Tage fortgeführt sondern nur das Jahr, d.h. nach 21.04.2013 folgt nicht 22.04.2013 sondern es folgt 21.04.2015 usw. Ich habe schon schon verschiedene Foren nach diesem Problem durchgesucht aber noch keine Antwort zu dem Thema gefunden, weiß jemand wie ich dieses Problem lösen kann?

...zur Frage

Ich wurde von Saturn Mitarbeiterin verarscht?

Hallo,

ich habe mir eine Kamera gekauft bei Saturn für 180€, als ich Sie nach 10 tagen zurück geben wollte sagte die Verkäuferin die mir die Kamera verkauft hatte 10 Tage zuvor das ich nur in Gutschein bekäme im selben wert und das Saturn nur Gutscheine gibt oder ein anderes Produkt und das auch schon immer. Später zuhause fällt mir auf das ich Weihnachten schonmal was zurück gegeben habe und das Geld sofort erhalten habe. Was haltet ihr davon?
ich werde morgen mich definitiv beschweren

...zur Frage

Microsoft Office Paket günstig oder kostenlos ?

Hallo Leute kann mir jemand sagen wo ich möglichst günstig oder kostenlos eine Office Paket bekomme brauche das für die schule Würde mich über SINNVOLLE antworten freuen

...zur Frage

Was möchtest Du wissen?