Excel zeit berechnen?

... komplette Frage anzeigen

5 Antworten

wie ist deine Tabelle aufgebaut? 

  • alles in einer Spalte?
  • alles in einer Zeile?
  • gleiche Stunden/Minuten in einer Zeile aber Unterschiedliche untereinander in Spalten?

Mach doch mal einen Screenshot , damit wir etwas besser verstehen, wie die Datengrundlage aussieht. Sind die Werte in einer Zelle, oder jeder Wert einzeln in einer Zelle vorhanden=

Zudem bin ich mir nicht sicher ob du tatsächlich die Sekunden addieren möchtest. Soll es nicht eher eine Differenz sein?

Zum Beispiel: 16:58:12, 16:58:15, 16:58:32

Wenn du dort die Sekunden addieren möchtest, dann hättest du 59 Sekunden. Die Differenz von ersten und letzten Eintrag sind allerdings nur 20 Sekunden.

Zusätzlich noch die Frage, ob es auch über einen Minuten- oder Stunden wechsel gehen kann? (16:59:58, 17:00:03, 17:00:17)


Antwort bewerten Vielen Dank für Deine Bewertung

Wenn die Zeiten in Spalte A stehen, leg eine bedingte Formatierung darüber.

Start → Formatvorlagen → Bedingte Formatierung → Neue Regel → Formel...

=A1+1/24/60/60<>A2

Ganz zufrieden bin ich damit nicht, aber vielleicht reicht dir der Ansatz.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
19.10.2016, 21:37

DH! gute Idee, das über bedingte Formatierung zu veranschaulichen!

Hab das noch ein klein wenig abgeändert (und zusätzlich auf Spalte C gebracht):

=C1+1/24/60/60>=C2

Das bezieht dann auch Sekundendoppel mit ein, Tageswechsel 23:59:59=>0:00:00 dürfte vorher schon funktioniert haben.

1

Hallo,

nicht besonders elegant, aber hier mal ein Lösungsansatz mit Hilfsspalten. Das geht davon aus, dass die Sprünge in deiner hochgeladenen Liste immer nur im 1-Sek-Bereich sind und alles darüber hinaus wird als neuer Start gewertet.

1. Hilfsspalte: Start einer Sektion festlegen.

=WENN(B2<>B1;"Start";WENN(UND(B2=B1;C2>C1+(1/24/60/60));"Start";""))

2. Hilfsspalte

=WENN(D2="Start";0;E1+C2-C1)

Die 2. Hilfsspalte zählt quasi, wie lange die jeweilige Sektion schon dauert.

LG, Chris

Antwort bewerten Vielen Dank für Deine Bewertung

wenn die Zeiten untereinander stehen (Spalte A) und wirklich ganz-sekundenweise gezählt wird, dann am einfachsten mit einer Hilfsspalte(B, Formel für B2 ):

=((A2=A1+"0:00:01")+B1)*(A2=A1+"0:00:01")

runterziehen.

A1 wird nicht mitgezählt, das darf aber auch  leer sein. Ein Text würde stören:  wenn Du eine Überschrift brauchst, setze sie in ein eine Zelle großes Textfeld oder setze sie in Spalte 2 rechtsbündig so: Ü'schriftSp1___Ü'schriftSp2

das zählt in jedem Block hoch und  liefert erst mal eine für die optische Auswertung brauchbare Darstellung, vor allem, wenn Du als Benutzerdefiniertes Zellformat (Strg+1, Karte Zahlen, Listenpunkt Benutzerdefiniert) zB das hier einträgst:

#;[rot]-#;[magenta]-


eine Darstellung nur der höchsten Zahlen jedes Blocks erhältst du mit einer weiteren Hilfsspalte(Formel in C2):
=WENN(B2>B3;B2;0)
und runterziehen

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
19.10.2016, 10:12

nachdem ich jetzt Deine Tabelle gesehen habe: da Du mehrere gleiche Zeiten untereinanderstehen hast, geht das nicht.

Habe jetzt aber keine Zeit mehr, die ungenaue Angabe (im Beispiel des Fragentexts ist die Differenz immer eine Sekunde!) hat mich jetzt ohnehin eine Stunde Bewegungstraining gekostet! (ich lass mich immer wieder dazu verführen, Termine für Antworten zu opfern, deren Basis sich hinterher als falsch herausstellt!)

0

also du schreibst die Zeiten die du willst in deine Tabelle.

- du suchst dir das Feld aus indem du die Summe berechnen willst

- dan auf rechts klick Zellen Formatieren.

- Benutzerdefiniert

- hh:mm:ss

- berechnest du die summe

jetzt sollte es richtig sein.

 

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?