Excel Zahlen runden und so wiedergeben

...komplette Frage anzeigen

6 Antworten

SO klappt das nur mit VBA.
Mit der Funktion RUNDEN(), wie Andere es beschreiben, kannst Du die eingegebene Zahl nur in einer anderen Zelle gerundet wiedergeben lassen, die Eingabe-Zelle bleibt unverändert.
Falls VBA, sprich ein Makro, für Dich eine Möglichkeit ist, mache folgendes:
Rechtsklick auf den Tabellenreiter (unten, da wo z.B. Tabelle1 steht) und dann auf "Code anzeigen...". In das große Fenster des VBA-Editors, der sich dann öffnet kopierst Du folgenden Code:

Private Sub Worksheet_Change(ByVal Target As Range)
If Not Intersect(Target, Range("A1:A100")) Is Nothing Then
    On Error GoTo ErrorHandler
    Application.EnableEvents = False
    Target.Value = Round(Target.Value, 2)
End If
ErrorHandler:
Application.EnableEvents = True
End Sub

Die Datei musst Du danach aber als .xlsm speichern, und Makros zulassen.
Den Bereich, für den das gilt, kannst Du anpassen, indem Du "A1:A100" entsprechend änderst.
Die Anzahl der Nachkommastellen wird durch die (....,2) angegeben.
Hilft Dir das?

Danke, der einzige der mich verstanden hat. Leider bin ich mit der Makrofunktion in Excel nicht vertraut. Habe es versucht aber es ist dann kein Unterschied in Excel vorzufinden. Muss ich das irgendwie speichern, wenn ich den Makrotext eingespeichert habe?

0
@dennixix

Nein, das sollte sofort klappen, auch ohne Speichern.
Allerdings nur im Bereich A1:A100 (wenn Du es nicht angepasst hast).
Und die Eingabe muss eine Zahl sein, d.h. der Bereich darf auch nicht als Text formatiert sein.
Sonst fällt mir im Moment kein Grund ein, warum das nicht klappen sollte.
Sonst erweitere das Makro mal so:

Private Sub Worksheet_Change(ByVal Target As Range)
If Not Intersect(Target, Range("A1:A100")) Is Nothing Then
    MsgBox "Bereich richtig"
    On Error GoTo ErrorHandler
    Application.EnableEvents = False
    Target.Value = Round(Target.Value, 2)
    MsgBox "Gerundet"
End If
ErrorHandler:
Application.EnableEvents = True
End Sub

Und schau was passiert.

0

Rechtsklick in die Zelle -> Zellen formatieren --> Auf dem Reiter "ZAHLEN" die Kategorie "zahl" wählen. Unter Dezimalstellen kannst du angeben, auf wieviel Stellen er nach dem Komma runden soll

nicht ganz richtig.

Format ändert nur die Anzeige, nicht den Inhalt der Zelle.

Excel bietet die Fkt runden(), die nach den übölichen Regeln rundet und dann mit dem gerundeten Wert weiterrechnet

0

Warum gibst du nicht gleich 2 Stellen nach dem Komma ein und lässt den Rest weg?

Ansonsten kannst du die Zellen formatieren, dann als Format Zahl wählen und 2 Nachkommastellen wählen.

Hi,

dafür gibt es die Funktion RUNDEN. Du gibst ein =RUNDEN(Zahl;Anzahl der Stellen)

Ich hoffe das hilft Dir weiter. Wenn Du noch Probleme hast melde Dich, dann schau ich ob ich weiter helfen kann.

Gruß Yoriika

Gib einfach in youtube ein: mit excel zahlen runden

Mit der runden()-Funktion, wenn du D7 runden willst:

=RUNDEN(D7;2)

Was möchtest Du wissen?