excel zahl finden?

... komplette Frage anzeigen

1 Antwort

Wenn der Bereich, in dem der zu suchede Text vorkommt, nur eine Spalte (oder Zeile) ist, dann kannst du mit

=VERGLEICH("*"&B1&"*";A1:A99;0)

sehen, an welcher Stelle (bzw. in der wievielten Zeile) der Text aus B1 (dein Suchfeld) in A1:A99 vorkommt.

Wenn der Bereich mehrere Zeilen und Spalten umfasst, ist das so nicht möglich.

Du könntest allerdings die Bedingte Formatierung verwenden, um das gefundene Feld hervorzuheben. Dafür markierst du den Bereich, erstellst eine neue Regel mit "Formel ist..." und verwendest als Formel:

=NICHT(ISTFEHLER(FINDEN($E$1;A1)))

und wählst das Format aus, z.B. farbiger Hintergrund. In diesm Beispiel ist E1 das Suchfeld.

Kommentar von Iamiam
25.12.2015, 16:26

Das mit der Bedingten Formatierung ist eine gute Idee (Bin da ausnahmsweise auch mal dafür). Ginge das als Formel nicht einfacher =$E$1 ?? wenn das WAHR ist, ist die Bedingung doch erfüllt?

vllt denken wir

Zum Suchen per Formel mit Adressenrückgabe siehe meine AW auf die zuvor gestellte Frage www.gutefrage.net/frage/excel-suchfunktion-zelle-anzeigen?

die ich hier nicht wiederhole.

1

Was möchtest Du wissen?