Excel "Zählenwenn" mit Bezug auf Zelle

6 Antworten

ich verstehe in diesem Fall Die Funktion SUMMENPRODUKT nicht. Welche Summe bildest du von was und was soll hier malgenommen werden. Versuche einfach mal in Worte zu fassen was du genau erreichen möchtest ohne Excelformeln ohne alles. nur beschreiben was passieren soll, eventuell mit einem Beispielbild.

vor und nach dem Wort "rot" soll ein Sternchen stehen, dass hat aber das Skript von gutefrage.net verschluckt. das gleiche auch unten bei "Sternchen[A1]Sternchen".

Du musst das Sternchen einrahmen entweder mit je einem Leerzeichen: * oder mit je einem underbar xs*fd (die werden stattdessen verschluckt) oder je zwei Accenten ´´ oder : ´´*´´ (Accent Aiguille) und Accent grave, da könnte es weitere Komplikationen geben:*`` die sind nämlich Auslöser für Schrift Courier (äquidistant). alles ziemlich verwickelt hier!

0

Es gibt etliche Such-/Zählfunktionen in xl, je nach Aufgabenstellung:
in Einzelzelle:
=FINDEN("rot";AH2;1) (exakte Groß-/Kleinschreibung) oder
=SUCHEN("rot";AH2;1) (Groß=klein) [Wildcards nicht zulässig]
beide auch =suchen(A1;AH2;n) (sprich: suche A1 in AH2 ab dem n-ten Zeichen)
Suchen liefert für rot in A1 und Vollkornbrotscheibe in AH2 : 10(-tes++ Zeichen)
finden liefert für rot in A1 und Rottach-Egern #Wert, weil R groß geschrieben.

=ZÄHLENWENN(AH2;A1) liefert 0
=ZÄHLENWENN(AH2;"*"&A1&"*") dagegen 1 in beiden Fällen (-brot-, Rottach-)
=ZÄHLENWENN(AH1:AH4;"*"&A1&"*") gibt die Anzahl der Funde im Bereich AH1:AH4zurück
ZÄHLENWENN funktioniert mit ALLEN BereichsFORMEN, auch mit zusammengesetzten)

siehe auch
www.gutefrage.net/frage/excel-hilfe-es-geht-um-eine-zaehlenwenn-formel

=VERGLEICH(A1;AH2;0) liefert #NV

=VERGLEICH("*"&A1&"*";AH2;0) liefert 1 (String ist in der EINEN=ERSTEN Zelle zu finden)

=VERGLEICH("*"&A1&"*";2:2;0) dagegen 34 (Sp.AH liefert die 34.Zelle in der ganzen Zeile)

=VERGLEICH("*"&A1&"*";AH:AH;0) liefert 2 (Zeile 2 bringt die 2. Zelle der ganzen Spalte ein.

Vergleich gibt nur EINE ( bei Typ=0 die ERSTE) Findung zurück!
VERGLEICH funktioniert NUR BEI EINSPALTIGEN ODER EINZEILIGEN BEREICHEN!

Oder meinst Du die Frage so: wenn in A2 etwas steht, wo A1 drin vorkommt, dann soll eine Zahl in Zelle AH2 verwendet werden?
dann mit rot in A1, verrottet inA2 , 123 in AH2:

=SUMMEWENN(A2;"*"&A1&"*";AH2) ergibt 123
=SUMMEWENN(A2;A1;AH2) dagegen 0
(Summewenn ist fast gleich wie Zählenwenn, nur dass da noch der zu summierende Zahlenbereich drangehängt wird, Zellenzahl und Form muss in beiden Bereichen übereinstimmen)

zu den Wildcards:
* kann alles oder auch NICHTS sein, ? steht für genau EIN Zeichen.
Sogar
"?"&"ro"&"*"&"t"&"*" wäre möglich und liefert bei Brot ein positives Ergebnis (* steht hier für nichts), auch bei Protzig und bei Prominentengala.
Kein Ergebnis dagegen bei Verrohungstendenz, weil Ver aus 3 Zeichen besteht.

Excel: Verketteten Text auslesen?

Stehe gerade aufm Schlauch. Ich verkette in EXCEL zwei Zelle um einen Dateinamen zu generieren. Beispiel: Zelleinhalt A1=123. Zelleninhalt A2=ABC. Formel in Zelle A3:=VERKETTEN(A1;A2)

Angezeigt wird das verkettete Ergebnis. Nun möchte ich den so generierten Dateinamen kopieren. Dabei wir aber nur die in der Zelle Formel angezeigt. Mit dem KOPIEREN, EINFÜGEN und WERT einfügen Befehl ist es natürlich möglich in einer weiteren Zelle der Wert anzuzeigen. Wie aber bekomme ich Excel dazu dies direkt in eine Zelle zu schreiben?

...zur Frage

Excel Formel wenn bestimmter Artiken dann Preis?

Wie ist die Formel wenn ich in Zelle A1 das Wort ''Regenschrim'' habe, dann in Zelle B1 den dazugehörigen Preis bekomme. Also wenn zb in Zelle A1 Regenschirm, dann 10.- Wenn in Zelle A1 aber Schuhe, dann 20.-

Ich habe die Produkte in einem Dropdown menu. Nun muss ich diese einfach noch mit dem Preis verlinken.

...zur Frage

Formel Erklärung Excel?

Heii,Also ich mache ein Reverat über Excel und so kam ich zu der Frage wie bilden sich die Formeln also zum Beispiel:

=SUMME(B1:B8)

Also nicht nur das Beispiel sondern wie bilden sich ansich die Formeln für alle rechnungen

Es wäre nett wenn mir jemand die Formelzusammensetzung erklären könnte....

....Danke :D LG Ewii

...zur Frage

Wie bleibt in Excel A1 in einer Formel beim Runterziehen immer A1

Also, wenn ich in eine Formel die Zelle A1 verwerte und ich die Formel auf andere anwenden soll, dann soll A1 in der Formel immer A1 bleiben und nicht A2 werden, weil ich da nämlich nichts stehen habe...

...zur Frage

Excel Formel Tabellenblatt-übergreifend

Hi Leute,

nochmal ein kleiner Nachtrag zu einer bereits gestellten Frage von mir.

Beispiel: a1=Haus, b1=Tür, c1=5, d1=Garten, e1=Stuhl, f1=5, a2=Auto, b2=Fenster, c2=7, d2=Büro, e2=Tisch, f2=2

In a3 schreibe ich z.B. "Garten". In a4 kommt jetzt die Formel. Ausgegeben werden soll der Wert, der rechts neben dem gesuchten Begriff steht. Also in dem Fall ist "Stuhl" das Ergebnis. Der Suchbereich geht also über mehrere Spalten und Zeilen.

Die Formel dafür lautet:

=(INDIREKT(ADRESSE(SUMMENPRODUKT((A1:F2=A3)ZEILE(1:2));SUMMENPRODUKT((A1:F2=A3)SPALTE(A:F))+1)))

Und jetzt dazu meine Frage: Muss ich, wenn ich diese Formel Tabellenblatt-übergreifend nutzen möchte irgendwas ändern? Wenn ich alles in einem Tabellenblatt habe funktioniert es, in 2 verschiedenen aber nicht. Also in "Tabelle1" stehen die Werte und in "Tabelle2" die Formel. Kommt dann aber immer 0 raus.

...zur Frage

EXCEL Formel gesucht ( Kniffel programmieren)

Hallo, ich soll in Informatik das Spiel Kniffel in Excel programmieren. Ich habe soweit auch schon alles fertig. Das Einzige, dass mir noch fehlt ist eine Formel um die 5 Zufallswürfel, die mit dem Befehl ZUFALLSBEREICH 1;6 , per Klick auf ein Kästchen beim nächsten Wurf nicht mehr neu würfeln. Also ganz kurz nochmal: Ich habe 5 Würfel, die auch würfeln. Ich brauche nur noch eine Formel um bestimmte Würfel, die man anklickt bei einem erneuten Wurf nicht mehr würfeln. Zusätzlich soll es eine Sperre geben, dass mannl nur 3x würfeln kann.

Danke für eure Hilfe.

...zur Frage

Was möchtest Du wissen?