Excel: Wie kann ich mich bei einer Wenn Funktion auf Nachbarzellen beziehen?

...komplette Frage anzeigen

4 Antworten

=SUMMEWENN(A:A;"Auto";B:B)
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Suboptimierer
28.07.2016, 12:06

Bitte azmd108 auszeichnen, falls diese Antwort richtig sein sollte. Der User war schneller.

0

Das Finden ist relativ einfach:

=WENN(ISTFEHLER(FINDEN("Auto";A1)>0);mach nix;mach was)

Aber das Aufsummieren mehrerer Zahlen aus einer einzigen Zelle ist etwas komplizierter. Dazu müsste man zumindest erst mal wissen, wie diese Zahlen getrennt sind.

Antwort bewerten Vielen Dank für Deine Bewertung

Das wäre mit einer Funktion wahrscheinlich ziemlich aufwändig. Ich würde dir empfehlen, das über eine Pivot-Tabelle zu machen.

Überschriften für Spalte A und B machen (z.B. Beschreibung und Betrag), Spalte A und B markieren, dann auf Einfügen > Pivot-Table, Ok klicken. Dann kommen rechts ein paar Fenster. Oben kannst du ein Häkchen bei Beschreibung und Betrag reinmachen. Unten kannst du Beschreibung in das Feld "Zeilenbeschriftung" reinziehen und Betrag ins Feld "Werte" reinziehen. Dann klick auf die Zeile, die in Werte drinsteht, auf "Wertfeldeinstellungen" gehen und dort "Summe" auswählen.

Hört sich erstmal kompliziert an, aber danach hast du eine kleine Tabelle mit allen unterschiedlichen Posten und den dazugehörigen Summen.

Als nächsten Schritt könntest du die Daten dann noch in einem Datenbankprogramm pflegen, weil Excel dafür eigentlich nicht wirklich geeignet ist.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von azmd108
28.07.2016, 11:53

SUMMEWENN tuts auch ;)

0

=SUMMEWENN(A:A;"Auto";B:B)

A:A Suchbereich, wo der Text steht
B:B Bereich, wo summiert werden soll

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von sephiroth88
28.07.2016, 11:53

Ich wusste es ist ganz einfach^^

Danke!

1

Was möchtest Du wissen?