Excel: Wie kann ich den Inhalt einer Zelle in einer Funktion verwenden?

...komplette Frage anzeigen Beispieltabelle - (Informatik, Microsoft, Excel)

2 Antworten

=Mittelwert(indirekt("A1:A"&Vergleich(B1;A1:A100;0)))

oder, wenn Du den Mittelwert zwischen zwei GrenzZellen mit ihren Werten in B1 und B2 suchst,

=Mittelwert(indirekt("A"&Vergleich(B1;A1:A100;0)&":A"&Vergleich(B2;A1:A100;0)))

Das ist aber nicht zu verwechseln mit der Mittelwertbildung der Werte zwischen zwei Grenzen, die nicht von vornherein lokalisiert sind:

=(Summewenn(A1:A100;"<B2";A1:A100)-Summewenn(A1:A100;"<B1";A1:A100))/
(Zählenwenn(A1:A100;"<B2";A1:A100)-Zählenwenn(A1:A100;"<B1";A1:A100))

ich glaube, es gibt neuerdings auch Mittelwertwenn(), da habe ich aber keine Erfahrung für 2 Bedingungen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von DeeDee07
21.07.2016, 20:25

Interessant, wie eine Frage unterschiedlich interpretiert werden kann. Intuitiv (durch die Formel und den Screenshot in der Frage) hätte ich es wie Jackie gelöst und denke, dass es auch so gefragt war.

Allerdings entspricht deine Lösung tatsächlich dem Teil in der Frage

von A1 bis zur Zeile mit dem Wert in der Zelle B1

Für bedingten Mittelwert mit mehr als einer Bedingung gibt es MITTELWERTWENNS.

3

das machst du so

=MITTELWERT(INDIREKT("A1:A"&B1))
Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?