Excel. Wie erstelle ich diese komplizierte Wenn-Dann-Sonst Formel?

...komplette Frage anzeigen

2 Antworten

Dass Du da am verzweifeln bist, kann ich mir lebhaft vorstellen. Ich kann leider nicht alle Einzelheiten nachvollziehen, wäre abendfüllend. Aber vielleicht kann ich Dir mit folgendem Entwurf weiterhelfen:

=WENN(UND('T1'!C2="Nein";'T1'!H2="10.07 - 12.07");ZEICHEN(97+(LINKS('T1'!H2;5)-LINKS("10.07.";5))/3);WENN(UND('T1'!B2='T2'!B3;'T1'!H2="10.07 - 12.07";'T1'!C2="Ja";'T1'!D2="10";'T1'!E2="7";'T1'!G2='T2'!D2);))

Benenne Deine Tabellen erst mal kurz (T1, T2). _ Die gesammelten Bedingungen am Anfang sind im zweiten Wenn der Formel in der UND-Klammer. Dann kommen die vorgeschalteten Bedingungen, ich hab mal nur das NEIN plus Datumsdifferenz =>a, b... als Modell dargestellt, weil das vielleicht die größten Probleme macht:

ZEICHEN(97) ist a, +1=>b, +2=>c _ die +0, +1, +2 werden aus der Datumsdifferenz/3 erzeugt, wobei ich den linken Teil als Leitzahl genommen habe. Müsste auch bei Monatswechsel gehen, nicht bei Jahreswechsel.

Die weiteren Deiner vielen Bedingungen musst Du erst mal hierarchisch einstufen und nach vermutlich vorne vor das jetzt 2.wenn rausziehen. xl erlaubt 8Klammerebenen, Du musst also aufpassen, dass es nicht zuviele werden. Sind Bedingungen doppelt definiert, musst Du aufpassen, dass Dir nicht eine vordere alles hintere rauswirft.

Ob andere Programme als xl die Anführungszeichen und Text<=>Datumsumwandlungen gleichermassen erledigen, weiß ich ohnehin nicht.

Vielleicht hilft Dir das wenigstens ein bißchen weiter!

also:

du machst beide dokumente auf, klickst bei dem feld wo du den text hin haben willst drauf, gibst ein istgleichzeichen = ein, dann klickst du im anderen dokument auf das feld das du übertragen haben willst, gehst wieder aufs andere dokument und jetzt siehst du das nach dem istgleichzeichen irgendwas steht. enter und fertig^^

also so übertragst du den wert von einem feld zum anderen, das andere weiß ich auch nicht xD

Wie eine einfache Wenn-Dann-Sonst Funktion geht, ist mir klar.

Nur ich hätte gerne einen Antwort speziell auf mein Problem :)

0
@FlapyGermany

ist "10.07 - 12.07" immer gleich geschrieben oder taucht da auch "2.07 - 6.07" und nicht "02.07 - 06.07" auf?

Und geht das auch über die Monatsgrenze? also "30.07 - 01.08" ? Muss man bei Textauflösungen alles wissen!

0

Was möchtest Du wissen?