Excel. Wie erstelle ich diese komplizierte Wenn-Dann-Sonst Formel?

2 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Dass Du da am verzweifeln bist, kann ich mir lebhaft vorstellen. Ich kann leider nicht alle Einzelheiten nachvollziehen, wäre abendfüllend. Aber vielleicht kann ich Dir mit folgendem Entwurf weiterhelfen:

=WENN(UND('T1'!C2="Nein";'T1'!H2="10.07 - 12.07");ZEICHEN(97+(LINKS('T1'!H2;5)-LINKS("10.07.";5))/3);WENN(UND('T1'!B2='T2'!B3;'T1'!H2="10.07 - 12.07";'T1'!C2="Ja";'T1'!D2="10";'T1'!E2="7";'T1'!G2='T2'!D2);))

Benenne Deine Tabellen erst mal kurz (T1, T2). _ Die gesammelten Bedingungen am Anfang sind im zweiten Wenn der Formel in der UND-Klammer. Dann kommen die vorgeschalteten Bedingungen, ich hab mal nur das NEIN plus Datumsdifferenz =>a, b... als Modell dargestellt, weil das vielleicht die größten Probleme macht:

ZEICHEN(97) ist a, +1=>b, +2=>c _ die +0, +1, +2 werden aus der Datumsdifferenz/3 erzeugt, wobei ich den linken Teil als Leitzahl genommen habe. Müsste auch bei Monatswechsel gehen, nicht bei Jahreswechsel.

Die weiteren Deiner vielen Bedingungen musst Du erst mal hierarchisch einstufen und nach vermutlich vorne vor das jetzt 2.wenn rausziehen. xl erlaubt 8Klammerebenen, Du musst also aufpassen, dass es nicht zuviele werden. Sind Bedingungen doppelt definiert, musst Du aufpassen, dass Dir nicht eine vordere alles hintere rauswirft.

Ob andere Programme als xl die Anführungszeichen und Text<=>Datumsumwandlungen gleichermassen erledigen, weiß ich ohnehin nicht.

Vielleicht hilft Dir das wenigstens ein bißchen weiter!

also:

du machst beide dokumente auf, klickst bei dem feld wo du den text hin haben willst drauf, gibst ein istgleichzeichen = ein, dann klickst du im anderen dokument auf das feld das du übertragen haben willst, gehst wieder aufs andere dokument und jetzt siehst du das nach dem istgleichzeichen irgendwas steht. enter und fertig^^

also so übertragst du den wert von einem feld zum anderen, das andere weiß ich auch nicht xD

Wie eine einfache Wenn-Dann-Sonst Funktion geht, ist mir klar.

Nur ich hätte gerne einen Antwort speziell auf mein Problem :)

0
@FlapyGermany

ist "10.07 - 12.07" immer gleich geschrieben oder taucht da auch "2.07 - 6.07" und nicht "02.07 - 06.07" auf?

Und geht das auch über die Monatsgrenze? also "30.07 - 01.08" ? Muss man bei Textauflösungen alles wissen!

0

Excel Formel über 2 Tabellenblätter

Hallo Ihr Lieben,

hab ne Frage zu Excel: stellt Euch vor, Ihr habt 2 identische Tabellenblätter. Nun möchte ich, dass, wenn z.B. das Feld B3 auf dem einen Tabellenblatt ein "K"enthält, dass auf dem anderen Tabellenblatt das Feld B3 rot leuchten soll. Es muss also eine bedingte Formatierung (?) sein, die ich nicht hinbekomme. Ich suche mir noch den Wolf! Könnt Ihr mir helfen? Liebe Grüße Ursula

...zur Frage

Excel VBA: Werte aus Eingabefeld in eine Tabelle eintragen?

Hallo, VBA ist nicht meine Welt, daher hoffe ich hier auf eine kleine Unterstützung. Ich brauche ein Makro, welches sich aus drei Eingabefelder ("B1"; "B2" und "B3") den "B3" Wert entnimmt und in einer Tabelle diesen Wert einträgt. Die Tabelle ist wie folgt aufgebaut: Der Wert (Text), welcher in "B1" steht befindet sich irgendwo zwischen "A7" und "A65" und "B2" befindet sich irgendwo zwischen "C6" und "BB6". Vielen Dank im Voraus!

...zur Frage

Excel Text Kategorisierung anhand von Keywords?

Hallo an alle!

Ich stehe vor folgender Aufgabe und habe bis leider keine Lösungsvorschläge gefunden. Ich möchte einzelne Textzellen in einem Excel-Sheet mehrerer Prüfungen unterziehen, um schlussendlich anhand enthaltener Keywords eine Zelle einer Kategorie zuordnen zu können.

Das würde folgendermaßen aussehen: Tabellenblatt 1:

   A        B

1 Text

2 Text

3 Text

4 ...

Tabellenblatt 2:

  A         B

1 Kategorie1 | Keyword 1; Keyword 2; Keyword 3

2 Kategorie2 | Keyword 4; Keyword 5; Keyword 6

Prüfung1: Wenn ein Keyword aus [Tabellenblatt 2, B1] in [Tabellenblatt 1, A1] enthalten ist, dann in [Tabellenblatt 1, Spalte B] ausgeben "Kategorie 1".

Prüfung 2: Wenn ein Keyword aus [Tabellenblatt 2, B2 in [Tabellenblatt 1, A1] enthalten ist, dann in [Tabellenblatt 1, Spalte B] ausgeben "Kategorie 2".

Ist so etwas mit Excel überhaupt noch zu lösen? Verneige mich jetzt schon vor allen Excel-Gurus, die hier vielleicht weiterhelfen können. Danke!!

...zur Frage

Formel in Excel funktioniert nicht?

Hallo zusammen. Ich wollte mir mal eine bessere Berechnung für meine Noten zulegen. Mit Excel kam ich da meist gut zurecht.

Ich habe folgendes Problem:

Ich habe z.B. in Mathe einen Schnitt aus allen Klassenarbeiten und einen aus allen Tests. Verhältnis: KA-Schnitt mal 4; test-Schnitt mal 1.

Nun soll daraus der gesamte Schriftliche Schnitt berechnet werden.

In B2 steht der KA-Schnitt; in C2 der Test-Schnitt; in D2 der schriftliche Schnitt.

In D2 habe ich dann diese Formel genommen:

=WENN(UND(B2>0;C2>0;ISTZAHL(B2);ISTZAHL(C2));MITTELWERT(B2;B2;B2;B2;C2);WENN(UND(B2>0;NICHT(C2>0);ISTZAHL(B2));B2;WENN(UND(NICHT(B2>0);C2>0; ISTZAHL(C2));C2;"")))

Denn, wenn nur B2 gefüllt ist, soll dieser Wert auch in D2 stehen; dasselbe bei C2.

Wenn beide Zellen mit Werten gefüllt sind soll der oben erläuterte Schnitt berechnet werden.

Jetzt ist es bei mir aber so, dass, wenn nur in einer der Zellen (B2/C2) ein Wert steht, D2 gänzlich leer bleibt.

Ach ja: Ich habe Excel 2010 und in B2 und C2 stehen Formeln.

Danke für eure Hilfe. Mensch0000000

...zur Frage

Bilder in Excel Tabelle fixieren. Geht das und wenn ja wie?

Ich möchte in eine Excel Tabelle Bilder einfügen und zwar so das es fixiert ist. Versuche es mal zu erklären: Also ich nehme ein Bilder und füge sie in Reihe 2 Spalte A bis D ein. In Reihe 3 schreibe ich dann je einen kurzen Text dazu. Nun möchte ich aber über Reihe 2 noch weitere Reihen einfügen. Wenn ich das aber mache, bleiben die Bilder nicht in den Kästen. Ist es also möglich die Bilder sozusagen in den Kästchen "festzukleben"?

Sorry habe nicht so viele Erfahrung mit Excel und mit Fachbegriffen....

...zur Frage

Excel: Text in anderes Feld übernehmen

Hallo,

Ich habe ein Problem mit Excel.

In B2 steht zB. das Wort "Hallo".

Nun gebe ich in B3 eine "1" ein.

Welche Formel benötigt B4 damit der selbe Text wie in B2 erscheint sobald in B3 eine "1" steht ??

Danke für eure Hilfe :)

...zur Frage

Was möchtest Du wissen?