Excel: Werte der 3 aktuellsten Jahre summieren

...komplette Frage anzeigen

3 Antworten

Ich hätte auch gedacht, dass es genügt die Bezüge absolut zu setzen, also $-Zeichen davor zu schreiben, aber Excel ändert, beim Einfügen einer Zelle/Spalte die Bezüge trotzdem!
Um das zu verhindern bleib wohl nur der Weg über Indirekt.
Für die Summe der Werte der Spalten F,G,H in der selben Zeile, sollte das so klappen:

=SUMME(INDIREKT("F"&ZEILE()&":H"&ZEILE()))

Funktioniert es?

Du musst vor die Spaltenangaben in der Formel ein $-Zeichen setzen, dann bleibt die Referenz auf diese Spalten auch erhalten, wenn Du neue Spalten einfügst : z.B. $F., $G., $H..,...

Hätte ich auch gedacht, aber Excel ändert - beim Einfügen - die Bezüge trotz absoluter Referenzierung.

0

Ich nutze für solche Fälle immer die Funktion Bereich.Verschieben. In Deinem falle sähe die Formel so aus: Summe(Bereich.verschieben($A$1;1;5;1000;3)) Hier würden jetzt alle Zahlen im Bereich F2:H100 summiert werden. In LibreOffie heißt die Funktion übrigens Verschieben.

DH!

Super Idee!

0

Was möchtest Du wissen?