Excel wert je nach zeit und Kilometer hinzurechnen?

... komplette Frage anzeigen

3 Antworten

So neue Antwort mit Bild und etwas systematischer aufgebaut.
Vielleicht fällt einem noch eine einfachere Formel ein - wenn nicht sollte man auf jeden Fall versuchen, nicht zuviele Variablen (wie Preise) direkt in die Formel zu packen. Sonst werden spätere Änderungen richtig kompliziert.

Ich kann leider keine fertige Datei ins Internet stellen, daher Bild und Formeln zum reinkopieren.

Fahrtdaten  und die Einstellungen (Beginn der teurer Zeiten, Preise ...) trägst Du einfach als feste Werte ein. Dabei nur auf die Zellformate achten: Uhrzeit, Zahl und Währung

F12: (Dauer Tagtarif)

=MAX(;1-MAX(B2;F2)+MAX(;F3-B2)+MIN(B3;F3)+(B3>F2)*(B3-F2)-(B2<B3)*(1-(F2-F3))-(F2<F3)*(B3+(B2>B3)-B2))*(B2<>B3)*(F2<>F3)

F13 (Dauer Nachttarif)

=REST(B3-B2;1)-MAX(;1-MAX(B2;F2)+MAX(;F3-B2)+MIN(B3;F3)+(B3>F2)*(B3-F2)-(B2<B3)*(1-(F2-F3))-(F2<F3)*(B3+(B2>B3)-B2))*(B2<>B3)*(F2<>F3)

F14 (Kilometer bis zum Grenzwert)
=MIN(100;B4)

F15 (Zusätzliche Kilometer)
=MAX(B4-100;0)

Die Aufteilung der Kilometer bis 100 und darüber hinaus könnte man sich ggf. auch sparen, aber so ist es noch eindeutiger nachzuvollziehen.

G12 (Kosten Tagtarif)
=F12*24*F4    -> an der Stelle wichtig: Excel zeigt beim Format Uhrzeit zwar "12:00" an, rechnet aber intern mit Dezimalzahlen. 1 Tag = 24h. Daher ist eine Stunde 1/24. 12 Stunden wäre also 12/24 = 0,5 nach Excellogik. Durch das Multiplizieren mit 24 erhält man den Wert in "richtigen" Stunden

G13 (Kosten Nacht)
=F13*24*F5

G14 (Kosten km bis 100)
=F14*F7

G15 (Kosten zusätzliche KM)
=F15*F8

Der Gesamtpreis in B6 ist dann einfach die Summe
=SUMME(G12:G15)

Antwort bewerten Vielen Dank für Deine Bewertung

Was sind denn die Parameter für die Berechnung? Eine Zeitdauer mit Beginn und Ende sowie eine Entfernung?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von dreamboy1997
12.05.2016, 12:35

Beispiel man Fahrt von 20 - 6 Uhr weg, dann sind es ja 2 Preis Kategorien. 7-23 wird dann 2,50 €berechnet und 0-6 0,5€. Es sind 120 Kilometer beispielsweise dann ist es für Kilometer 1-100 0,22 jeder weiterer 0.18

0

Mit einer wenn-funktion.
Sieh dir dieses Video an...

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?