Excel Wenn leer fehler Meldung, bei wenn Funktion, wer kann mir helfen?

3 Antworten

In der letzten (innersten) WENN-Schachtel fehlt das SONST-Argument. Wenn also alle Bedingungen nicht erfüllt sind, wird der innerste-Sonst-Wert herangezogen. Nicht gesetzte DANN- oder SONST-Argumente gibt Excel dann standardmäßig als WAHR bzw. FALSCH aus.

Im übrigen: Statt solch ellenlanger WENN-Verschachtelungen zu verwenden, empfehle ich dir, eine kleine Verweis-Tabelle zu erstellen und den Wert per SVERWEIS zu ermitteln. In deinem Fall ist das leicht möglich, da jede Prüfung den Wert von C6 abfragt.

Hallo dedee07
Leider weiss ich nicht wo das SONST fehlt? Bei wenn x dann sverweis?
Danke schön.
LG Coniel

0
@Coniel

Genau, was soll passieren, wenn C6 <> x?

Siehe dazu die Antwort von Oubyi. Beachte, dass der gutefrage-Editor mal wieder die * aus der Formel verschluckt hat.

1
@DeeDee07

Ach da waren Malzeichen nach dem B34. Dass die Strings Maßeinheiten sind, war mir auch nicht aufgefallen. Mich hatte schon gewundert, dass es eine so lange Liste gibt, bis Zeile 340000. Aber hätte ja wein können.

0

Meinst Du so?:

=WENN(ISTLEER(A34);"";(WENN(C6="l";B341000;WENN(C6="dl";B34100;WENN(C6="ml";B341;WENN(C6="cl";B3410;WENN(C6="g";B341;WENN(C6="kg";B341000;WENN(C6="Stk";SVERWEIS(A34;[Matrix.xlsx]Daten!$1:$1048576;20;FALSCH)*B34;WENN(C6="EL";SVERWEIS(A34;[Matrix.xlsx]Daten!$1:$1048576;22;0)*B34;WENN(C6="TL";SVERWEIS(A34;[Matrix.xlsx]Daten!$1:$1048576;21;0)*B34;WENN(C6="x";SVERWEIS(A34;[Matrix.xlsx]Daten!$1:$1048576;23;0)*B34;"DEIN WUNSCHERGEBNIS"))))))))))))

Woher ich das weiß:Beruf – IT-Administrator (i.R.)

Ich kann das jetzt natürlich so nicht direkt überprüfen. Ein Gedanke wäre aber statt ISTLEER(A34);"";blablabla folgendes zu versuchen: =WENN(A34="";"LEER";"NICHT LEER")

Dann sollte es möglich sein mit Deiner Anpassung das so hinzukriegen dass es funktioniert.

Also =WENN(A34="";"";(WENN(C6="l";B341000;WENN(C6="dl";B34100;WENN(C6="ml";B341;WENN(C6="cl";B3410;WENN(C6="g";B341;WENN(C6="kg";B341000;WENN(C6="Stk";SVERWEIS(A34;[Matrix.xlsx]Daten!$1:$1048576;20;FALSCH)B34;WENN(C6="EL";SVERWEIS(A34;[Matrix.xlsx]Daten!$1:$1048576;22;0)B34;WENN(C6="TL";SVERWEIS(A34;[Matrix.xlsx]Daten!$1:$1048576;21;0)B34;WENN(C6="x";SVERWEIS(A34;[Matrix.xlsx]Daten!$1:$1048576;23;0)B34))))))))))))

Nur jetzt 1zu1 übernommen.

Eventuell kannst Du Deine Formel ja auch behalten und einfach das ISTLEER negieren.

@DaMenzel

Jetzt funktioniert es wenn in A34 leer ist, jedoch nicht, wenn Text in A34 steht.

0
@Coniel

Dann stimmt mit den anderen Bedingungen was nicht. Was soll denn angezeigt werden?

0
@DaMenzel

es geht darum wenn ich für ein Rezept Bsp. 1 (B34) Liter Wasser (A34) habe, dies in Gramm umgerechnet werden soll. Nur so kann ich die Nährwerte pro 100 Gramm jeweils berechnen lassen.

0

Was möchtest Du wissen?