Excel Wenn-Funktion zu lang

...komplette Frage anzeigen

3 Antworten

Die Begrenzung auf 1+7 Klammerebenen gilt seit xl2007 nicht mehr (hab noch nicht ausprobiert, wieviele es jetzt sind, anscheinend mehr als 16!).

Unabhängig davon, dass man bei so vielen Verschachtelungen versucht, andere Funktionstypen einzusetzen - so wie das Achris in seiner AW vorgeführt hat, -
kann man die Zahl der Klammerebenen (fast) halbieren, wenn man eine erste Abfrage vorschaltet und damit die Abfragen gruppiert:
=wenn(oder(L3="QW";L3="WE";L3="ER";L3="RT";L3="TZ";L3="ZU");
wenn(L3="QW";K6;wenn(L3="WE";K7;wenn(L3="ER";K8;wenn(L3="RT"; K9;wenn(L3="TZ";K10;wenn(L3="ZU";K11;""))))));
wenn(L3="UI";K12;wenn(L3="IO";K13;wenn(L3="OP";K14;wenn(L3="PÜ"; K15;wenn(L3="ÜA";K16;wenn(L3="SD";K17;"-")))))))
Leerzeichen und Umbrüche sind nur aus Darstellungsgründen drin, ich glaube, xl ignoriert das jetzt, ansonsten rausmachen.

Damit kämst Du mit 8 Klammerebenen zurecht, falls ein anderes Problem die Achris-Lösung nicht zuließe.

Iamiam 22.01.2013, 01:14

in anderen Fällen kann man auch die Ergebnisse von Einzelabfragen verketten, nur ein verkürztes Beispiel zur Veranschaulichung:

=wenn(L3="QW";K6;"")&wenn(L3="WE";K7;"")&...&wenn(L3="SD";K17;"")

Das "-" kommt hier allerdings nicht rein, es sei denn mit einer Verdoppelung der Abfragen ähnlich oben:

wenn(wenn(L3="QW";K6;"")&wenn(L3="WE";K7;"")&...&wenn(L3="SD";K17;"")="";"-";wenn(L3="QW";K6;"")&wenn(L3="WE";K7;"")&...&wenn(L3="SD";K17;"")
oder -etwas kürzer- Abfrage mit der Oder-Fkt aus der Hauptantwort.
Ich hab zB folgende Funktion in meinem Kalender (AF12 ist das variable Datum):

=WENN(REST($AF12;14)=9;"?+TGSchach";"")&
WENN(REST($AF1214)=2;"TSSchach?";"")&
WENN(REST($AF12;7)=3;
WENN(UND(TAG($AF12<15TAG($AF12)>7);"Wan+Tri";" ")&
WENN(ODER(TAG($AF12)<8;UND(TAG($AF12)<22;TAG($AF12)>14));"Fli";)&
WENN(TAG($AF12)>21;"Hans";" ");" ")&
WENN(REST($AF12;14)=4;"HaZi+Chor";"")&
WENN(REST($AF12;14)=11;"Kino";"")&
WENN(REST($AF12;14)=11;"??";" ")&
WENN(REST($AF12;7)=5;"Sen-S";" ")&
WENN(REST($AF12;7)=6;"NSN";" ")

Mit einer ähnlich verketteten Fkt stelle ich die Resttage bis zur nächsten Leerung von Restmüll, Biotonne und Papier dar, damit ich ans Rausstellen denke.

0

Füge einige Zwischenspalten ein, die du dann ausblendest. Also wird zunächst ein bestimmtes Ergebnis (verdeckt) bei Bedarf in eine (verdeckte) Spalte kopiert, dann greift eine andere (verdeckte) Spalte mit Funktion darauf zu...

=INDEX(K6:K17;VERGLEICH(L3;{"QW";"WE";"ER";"RT";"TZ";"ZU";"UI";"IO";"OP";"PÜ";"ÜA";"SD"};0))

Alternativ kannst du die Lieferantennamen auch in die Zellen L6:L17 schreiben und dann die Formel entsprechend abwandeln zu:

=INDEX(K6:K17;VERGLEICH(L3;L6:L17;0))

Iamiam 22.01.2013, 00:09

die beste Lösung kommt gewiss
wieder mal von augsburgchris!
DH!

0
Iamiam 25.01.2013, 22:59
@Iamiam

@ Achris: ich denke, dass man die Index/Vgl-Kombi-Formel jedesmal wieder von Grund auf erklären muss, damit überhaupt eine Motivation besteht, sich damit zu befassen. Mir geht so langsam die Motivation dafür auch flöten, denn didaktisch ist das auf dem Stand der ersten Wenn-Beschäftigung kaum zu leisten, leider!

0
augsburgchris 01.02.2013, 14:58
@Iamiam

Für mi brauchts da koi extra Motivation. Ist quasi scho automatisiert.

0

Was möchtest Du wissen?