Excel Wenn Funktion vereinfachen?

4 Antworten

Trag doch mal die Formel als Quelltext ein.
In dieser Form nicht lesbar, da Teile der Formel als Formatierungszeichen verarbeitet wurden.
Zudem fehlen auch irgendwie ein paar Teile oder?
Die Wennfunktion hat ja gar kein Dann Wert
Ohne die Klärung wozu die Stufenweise Abfrage ist, kann man kaum helfen.

bei umfangreichen Stufenzuordnungen könnten statt Wenn Verschachtelung auch die Funktionen Sverweis, Index+Vergleich oder Wahl sinniger sein.

Das musst Du "rückwärts", also mit kleiner als, prüfen. Und wir müssten wissen, was als Ergebnis der Prüfung zurückgegeben werden soll.
Aber im Prinzip geht eine Verschachtelte WENN so:

=WENN((RUNDEN((A1-B2)*96;0)/96)<ZEITWERT("00:08");"A";WENN((RUNDEN((A1-B2)*96;0)/96)<ZEITWERT("00:23");"B";WENN((RUNDEN((A1-B2)*96;0)/96)<ZEITWERT("00:38");"C";"X")))

usw.
Wird aber für 8 Stunden heftig. Vielleicht findest Du eine andere Lösung?
Sonst beschreibe das Szenario mal genauer.

Woher ich das weiß:Beruf – IT-Administrator (i.R.)

Auf den ersten Blick: nein

Denn du machst ja immer eine verfeinerte Abfrage.

Woher ich das weiß:Beruf – Chief Information Officer

Wofür brauchst du diese Verschachtelung?

Was möchtest Du wissen?