Excel Wenn-Funktion HILFEEEE!

...komplette Frage anzeigen Foto der Excel-Tabelle - (Computer, Excel, Office)

1 Antwort

Summe WGK1 sollen nacher alle Konzentrationen mit der WGK 1 berechnet werden

Das ist doch der Kern, oder?
Das ist nur kompliziert, wenn Du auf Deiner WENN-Funktion bestehst, denn die ist DAFÜR nicht gemacht.
Angenommen, "Stoffname" steht in A1 (nächstes mal solltest Du die Zeilen und Spaltenköpfe mit in den Screenshot nehmen!), dann diese Formel in B8 (Summe WGK 1):

=SUMMEWENN(C2:C6;"WGK 1";B2:B6)

Allerdings hast Du dann, wie beschrieben, die Summe der Konzentrationen, ich kann mir nicht vorstellen, dass man damit wirklich etwas anfangen kann. Ich würde eher den Durchschnitt errechnen, das wäre dann:

=SUMMEWENN(C2:C6;"WGK 1";B2:B6)/ZÄHLENWENN(C2:C6;"WGK 1")

Hilft Dir das?

das hilft mir schon weiter... danke, allerdings ist das schon richtig das ich die Summe der WGK 1er Konzentrate und der 2er/3er extra aufgelistet haben möchte....

1 Problem steht mir noch vor Vollendung im Weg. Ich habe exakt die Formel benutzt die du mir Vorgeschlagen hast allerdings ergibt sich bei der Zusammenrechnung ein komisches Ergebnis. Excel nimmt nicht die Konzentrationswerte (1 + 1 + 1) sondern andere (100 + 100 + 100).

Hast du mir da vielleicht noch eine Lösung?

ich habe einen Screenshot falls dir das weiterhelfen würde... allerdings kann ich den nicht beifügen -.-

0
@SiggiSeidel

Was steht denn in den Zellen?
Steht da 1 oder steht da 1 % ???
Wie sind diese Zellen formatiert? Als Zahl oder als Prozent?
Wie ist die Formelzelle formatiert? Als Zahl oder als Prozent?

Vielleicht helfen Dir diese Fragen schon "auf die Sprünge", sonst wäre es am besten, wenn Du eine Beispieldatei bei einem Upload-Service (z.B. http://www.file-upload.net) hochladen und hier den Link einstellen könntest.
(Für einen Screenshot könntest Du hier auch eine ANTWORT auf Deine Frage geben, und den dort anhängen, ich bin aber nicht sicher, ob DER mir etwas nützen würde.)

0
@SiggiSeidel

Bilder kannst du hier hochladen und den Link hier veröffentlichen

0
@dkilli

Bilder hochladen geht aber blöder Weise NICHT in einem Kommentar, sondern nur in einer Antwort.
Aber Siggi stellt schon die nächste Frage.
Vielleicht interessiert ihn das hier schon nicht mehr!?

0
@dkilli

könnte es sein, dass Du gar nicht die Summe der Konzentrationen, sondern die Anzahl der Stoffe mit WGK1, WGK2, WGK3 brauchst? (dann nur Zählenwenn)

Die Summe macht nämlich wirklich keinen Sinn, wenn, dann Konzentration * Menge, das ergibt die jeweilige Menge Reinstoffe.

0
@Iamiam

Nachdem ich nochmal nachgedacht habe, könnte ich mir vorstellen, dass er doch die Summe braucht, nämlich um auszusagen, dass das Wasser mit insgesamt 5% verschiedener Stoffe der Klasse WGK 1 verschmutzt ist. Das können dann 1% des Stoffes A, 2% Stoff B und 2% Stoff C sein.

0
@Oubyi

Danke hat sich aber schon geklärt ich musste am Ende der Formel noch :100 machen, somit habe ich das richtige Ergebnis... Danke :)

0
@SiggiSeidel

Ja, das hängt mit der %-Einstellung zusammen.
Schön, dass Du es hinbekommen hast ☼

0

Was möchtest Du wissen?