Excel WENN Funktion ... brauche kurz hilfe?

...komplette Frage anzeigen

4 Antworten

Denke folgendes sollte gehen:

=WENN(F9>90;1;WENN(F9>89;2;WENN(F9>71;3;WENN(...))))

geht allerdings nur 7x glaube ich, da das die maximale Anzahl an WENN Verschachtelungen ist.

Brauchst du mehr als 7?

Lg Tobi

PWolff 21.02.2017, 21:36

Bei mehr als 3 geschachtelten ">="-Bedingungen überlege ich, ob ich das nicht sinnvoller mit SVERWEIS oder VERWEIS erledigen kann. (VERWEIS funktioniert auch mit direkt in der Formel erfassten Vektoren.)

2
Iamiam 21.02.2017, 23:37

7 bzw 8 Klammewrebenen, das war mal, mittlerweile sollen 64 Klammerebenen zugelassen sein. aber Suboptimierers Formel löst das mit einer!

(xl bietet eben eine Menge Funktionen über die in der Schule Vermittelten hinaus, das macht die Funktionalität aus, aber auch den Reiz!)

3

Muss es denn WENN sein? VERGLEICH geht auch.

=7-VERGLEICH(A1;{0;25;50;72;81;90})

Wenn ich das richtig verstanden habe willst du folgendes:

Wenn f9 >= 90% -> 1

Wenn f9 < 90% -> 91-f9

Genau das packst du jetzt in deine Wenn-Funktion:

=WENN(f9>=90;1;91-f9)

Was möchtest Du wissen?