Excel WENN DANN Funktion Eingabefehler?

... komplette Frage anzeigen

2 Antworten

  1. Bei UND(A8=0) kannst du dir das UND sparen.
  2. Die Fälle 999 und 1000 wurden gar nicht abgefangen. Statt A8<999 schreibst du A8<=999, statt A8>1000 schreibst du A8>=1000.
  3. Statt "0,120" reicht 0,12, denn du willst sicherlich keinen Text in der Spalte stehen haben, sondern eine Zahl. Füge mit Excelfunktionalitäten (Formatierungen) weitere Stellen hinzu.
  4. Deine Staffelung kannst du dir in deiner Formel sparen, denn alles was zwischen -1 und 500000 liegt (außer 0), wird "0,120" zugeordnet.
  5. Es fehlt ein abschließender Sonst-Zweig, der verwendet wird, wenn keine Bedingung erfüllt ist.
Kommentar von Jackie251
22.02.2016, 11:48

weiterhin könnte man anmerken das hier eine Verweisfunktion schon die bessere Wahl wäre als eine Wennschachtel

3
Kommentar von bunkertoni
22.02.2016, 11:54

Klasse vielen Dank!

Es ist nur bei diesem Produkt so, dass der Preis nicht sinkt - daher alles "0.120"!

0

Das geht viel einfacher. 

=WENN(A1<1000;A1;WENN(A1<5000;A1-500;WENN(A1<10000;A1-1000;A1-2000)))

Die Formel musst du nur anpassen und erweitern

Was möchtest Du wissen?