Excel: Welche Formel für leere Zeile?

... komplette Frage anzeigen

5 Antworten

So sieht die Tabelle aus. In Spalte B konnte ich diese Formel einfügen, in allen anderen Formeln kam mit der gleichen Formel ERROR raus.

=WENN(ANZAHL2(1:1)=0;...
Kommentar von Iamiam
20.09.2016, 13:08

Da darf aber sonst nichts in der Zeile stehen, auch nicht die Funktion!

0

alle Zählfunktionen mit "" liefern für ="" ein WAHR bzw eine Zahl, mit Ausnahme von =ISTLEER(Zelle)

=WENN(ISTLEER(Zelle);"") liefert also FALSCH (wenn das sonst-Argument fehlt, liefert zB =Wenn(0;1) Falsch)

Verwende also =Wenn(B6="";"";sonst) oder   =Wenn(AnzahlleereZellen(B6)=1;..;..) oder sonstwas.

="" ist übrigens ein (leerer) TEXT und wird von =Isttext(B6) mit WAHR beantwortet, aber Länge(B6) liefert 0 (jede Zahl: >0. Auch eine Testmöglichkeit).

Du siehst, nichts ist komplizierter als NICHTS!

Oder wolltest du was anderes?

Kommentar von Iamiam
20.09.2016, 13:56

ich nehme an, Du hast Dich verschrieben: In B6 ergäbe diese Formel ja Zirkelbezug!

Hast Du die Materialnamen aus einer Datenbank? Dann teste mal mit dem o.g. Länge(Zelle), ob nicht doch was drinsteht. Datenbanken verwenden auch oft das "geschützte" Leerzeichen [ =Zeichen(160), das bekommst Du heraus mit der Formel =Code(links(B6;1)) ]

Füge dazu irgendwo eine neue Spalte ein, hinterher kannst du die wieder löschen!

0
Kommentar von WildeHilde93
20.09.2016, 14:44

Ich bin leider total der Excel Dummie und bin nicht sicher, ob ich da hintersteige. Müste ich nicht die Formel in die oberste Zeil einfügen und mit B2 anfangen? Und dann die Formel runterziehen? Oder ist das nur ein Beispiel dafür, wie die Formel in der 6. Zeile aussehen müsste?

0
Kommentar von WildeHilde93
20.09.2016, 14:46

Entschuldige bitte, ich sehe grade, dass ich B6 weiter unten geschrieben  habe. Könntest du dich vielleicht auf das Bild beziehen, dass ich als Kommentar gepostet habe? So sieht die Tabelle nämlich aus.

0

Hallo,

es nicht eindeutig erkennbar was Du genau willst oder hast.

Falls Du in B2 eine Text-Verknüpfung zu einer anderen Datei haben willst (vorausgesetzt die Zellen/Zeilen-Zuordnung sind identisch) wäre als Beispiel diese Formel (alles zusammenschreiben) angebracht.

=WENN(UND(UND(C2=0;D2=0;E2=0));"";'C:\\Musterfile\\[Musterdatei.xlsx]Tabelle1'!B2)

Das ganze nach unten kopieren (Wichtig, keine $-Zeichen bei der Zellzuordnung verwenden).

Eigentlich arbeitet man in solchen Fällen mit dem "SVERWEIS".

Sind die Daten bereits verknüpft, oder stehen bereits in B2 drin und Du möchtest nur das man den Text nicht sieht, dann unter "Bedingte Formatierung" - "Neue Regel" - "Formel zur Ermittlung ..." - "Regelbeschreibung bearbeiten", folgende Formel eingeben.

=UND(UND(UND(C2=0;D2=0;E2=0)))

Auch hier keine $-Zeichen verwenden !

(siehe Abbildung)

Dann unter "Format" - "Schrift" - "Farbe", die Farbe "Weiß" wählen, mit "OK" jeweils bestätigen bis die bedingte Formatierung abgeschlossen ist.

Gruß Tron

"" wäre das Zeichen für leer

also =WENN(""; A; B)

so etwa?

Kommentar von WildeHilde93
20.09.2016, 12:47

Ich habe, als Beispiel, WENN(ISTLEER(B6);""; versucht, aber dann bekomme ich ERROR. In einer anderen Spalte hat es funktioniert. Es liegt nicht an einem Tippfehler etc, das habe ich überprüft.

0
Kommentar von WildeHilde93
20.09.2016, 12:48

Vielleicht kann man so besser verstehen, was ich meine.

0
Kommentar von WildeHilde93
20.09.2016, 12:50

So sieht sie aus:

0

Was möchtest Du wissen?