Excel Verweis Funktionen (Speziallfall)

... komplette Frage anzeigen

2 Antworten

Sorry, aber die Informationen reichen zumindest mir nicht aus, um dir darauf eine korrekte Antwort zu geben.

Wenn du von einer Tabelle auf eine andere Verweisen willst, brauchst du ja ein Suchkriterium, welches in beiden Tabellen gleich und EINMALIG ist.

Zumindest ist dies für mich nicht ersichtlich.

Am einfachsten wäre es, wenn du deine "Rohtabelle" irgendwo hochlädst, sodass man deine Datenbasis sehen kann.

Antwort bewerten Vielen Dank für Deine Bewertung

Wenn ich dich richtig verstehe, möchtest du alle Zeilen, die zum Unternehmen bspw. Fischer gehören auf bspw. Tabellenblatt2 und alle Ertl gehören auf Blatt3, Flughafen Blatt 4, ....

richtig?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Ortogonn
30.08.2013, 17:48

Wenn dem so sein sollte ....

Da du ja anscheinend über der Tabelle 2 Zeilen Platz hast, empfehle ich dir die auf dem Tabellenblatt anzuzeigende Firma (bspw. Fischer) oben drüber in eine sowieso leere Zelle zu schreiben. Dann kannst du auf allen Tabellenblättern dieselbe Formel verwenden und musst nur jeweils die anzuzeigende Firma einstellen.

Ich unterstelle jetzt mal, dass die anzuzeigende Firma in Zelle C1 reingeschrieben wird. Meine Formel wird sich von dort den Namen holen.
Weiter unterstelle ich, dass die Ursprungstabelle auf Blatt 1 von Zeile 4 bis Zeile 101 geht. Wenn es mehr Zeilen sind, musst du das anpassen.

Beispieldatei:
http://www.workupload.com/file/WQ9rbUnR


alle Tabellenblätter, wo was angezeigt/gefilter werden soll bekommen nachfolgende Formeln:

in Zelle A4 folgende Formel:

=WENN(ISTFEHLER(INDEX(Tabelle1!A$4:A$101;KKLEINSTE(WENN(Tabelle1!$D$4:$D$101=$C$1;ZEILE(Tabelle1!$A$4:$A$101);FALSCH);ZEILE(Tabelle1!$A1))-3));"";INDEX(Tabelle1!A$4:A$101;KKLEINSTE(WENN(Tabelle1!$D$4:$D$101=$C$1;ZEILE(Tabelle1!$A$4:$A$101);FALSCH);ZEILE(Tabelle1!$A1))-3))

Eingabe mit STRG+Shift+Return bestätigen, da es eine Matrixformel ist!

Da du Excel 2003 nutzt, ist die Formel zwecks Fehlerausblendung etwas länger als bei neueren Excelversionen. Die 2003er kennt die Funktion WENNFEHLER() noch nicht.

in Zelle B4:

=WENN(ISTFEHLER(INDEX(Tabelle1!B$4:B$101;KKLEINSTE(WENN(Tabelle1!$D$4:$D$101=$C$1;ZEILE(Tabelle1!$A$4:$A$101);FALSCH);ZEILE(Tabelle1!$A1))-3));"";INDEX(Tabelle1!B$4:B$101;KKLEINSTE(WENN(Tabelle1!$D$4:$D$101=$C$1;ZEILE(Tabelle1!$A$4:$A$101);FALSCH);ZEILE(Tabelle1!$A1))-3))

Eingabe mit STRG+Shift+Return bestätigen

in Zelle C4:

=WENN(ISTFEHLER(INDEX(Tabelle1!C$4:C$101;KKLEINSTE(WENN(Tabelle1!$D$4:$D$101=$C$1;ZEILE(Tabelle1!$A$4:$A$101);FALSCH);ZEILE(Tabelle1!$A1))-3));"";INDEX(Tabelle1!C$4:C$101;KKLEINSTE(WENN(Tabelle1!$D$4:$D$101=$C$1;ZEILE(Tabelle1!$A$4:$A$101);FALSCH);ZEILE(Tabelle1!$A1))-3))

Eingabe mit STRG+Shift+Return bestätigen

in Zelle D4:

=WENN(ISTFEHLER(INDEX(Tabelle1!D$4:D$101;KKLEINSTE(WENN(Tabelle1!$D$4:$D$101=$C$1;ZEILE(Tabelle1!$A$4:$A$101);FALSCH);ZEILE(Tabelle1!$A1))-3));"";INDEX(Tabelle1!D$4:D$101;KKLEINSTE(WENN(Tabelle1!$D$4:$D$101=$C$1;ZEILE(Tabelle1!$A$4:$A$101);FALSCH);ZEILE(Tabelle1!$A1))-3))

Eingabe mit STRG+Shift+Return bestätigen

Dann Zellen A4 bis D4 markieren und mittels Anfasser nach unten ziehen/kopieren - soweit wie du möchtest


Wichtig
Sollte der Inhalt deiner Tabelle auf Blatt 1 nicht in Zeile 4 beginnen wie auf deinem Bild, muss die Formel angepasst werden!
Und zwar zweimal der Abschnitt
ZEILE(Tabelle1!$A1))-3
wo aus der 3 dann eine andere Zahl werden muss. Es muss immer Startzeilennummer weniger 1 sein.

0

Was möchtest Du wissen?