Excel VBA mit Application.WorksheetFunction.Count eine Spalte Zählen (aber Doppelte Zahlen = 1)

...komplette Frage anzeigen

2 Antworten

Muss es unbedingt VBA sein?
Diese FORMEL würde das auch erledigen:

=SUMMENPRODUKT((A1:A99<>"")/ZÄHLENWENN(A1:A99;A1:A99&""))
oder, wenn es nur Zahlen sind sogar ganz knapp:
=SUMME((HÄUFIGKEIT(A:A;A:A)>0)1)*

Wenn es VBA sein muss, kannst Du ja versuchen, sie über WorksheeFunction zusammenzubauen.

Hilfe für die Formel habe ich hier bekommen:
http://www.excelformeln.de/formeln.html?welcher=42

Oubyi 30.06.2014, 12:41

P.S..
Sorry, bei der zweiten Formel habe ich mich mal wieder von dem antiken Editor hier überlisten lassen. Da fehlte ein Sternchen:

=SUMME((HÄUFIGKEIT(A:A;A:A)>0)*1)

1

Das geht nur mit ".Count" nicht.

Was möchtest Du wissen?