Excel: Text aus mehreren Zellen zusammenfügen?

3 Antworten

Du hast zwar die Lösung gefunden, aber ich kann Dich nur warnen, die Datei so zu verändern: Du wirst später den Text nur noch ganz schwer wieder trennen können.

Ich weiß nicht, warum Du das machen willst, aber behalte dir auf alle Fälle ein Backup der getrennten Einträge!

Warum willst du keine Trennzeichen zwischen den bisherigen Einzeleinträgen?

Tipp: Du kannst auch jederzeit schreiben: =A1&", "&B1&", "&C1

sowas belastet xl überhaupt nicht (bzw. nur äusserst geringfügig) und lässt sich dann problemlos wieder aufspalten. Kannst auch jedes andere Trennzeichen nehmen, zB &"٠"& oder &"∙"& (kannst Du hier rauskopieren) oder ein geschütztes> <LeerZ

Das geschützte Leerzeichen ist in xl =Zeichen(160) und wird hier leider in ein normales umgewandelt, deshalb =A1&ZEICHEN(160)&B1&ZEICHEN(160)&C1

In xl bleibt es erhalten, auch wenn man die Formel zu Wert umsetzt.

9

Ich mach das um eine Mandatsreferenz aus Nachnamen, Vornamen und ID-Nummer zu erstellen. Kann also jederzeit auch von Hand durchgeführt werden, mit der Formel kann man sich aber viel Zeit sparen.

0
40
@Fimmel

Ich weiß zwar nicht, was eine Mandsatsreferenz ist, aber wenn die Datei erhalten bleiben soll, gilt das oben gesagte. Kannst Du nicht das Vergleichsabbild entsprechend verändern?

0

Nimm mal folgende Formel:

=VERKETTEN(B2;C2;A2)

Es kann auch am Format deiner Tabelle liegen, das sollte aber bei dieser Formel kein Thema sein.

Ich habs schon rausgefunden. Meine Tabelle war komplett im "Text"-Format. Muss auf "Standard" umgestellt werden. 

Wie viele Millimeter ist der A bei Schriftgröße 11 groß?

Es würde mich mal interessieren, wie man von der Schriftgröße zur Größe in Millimeter umrechnet.

...zur Frage

Formel in Excel funktioniert nicht?

Hallo zusammen. Ich wollte mir mal eine bessere Berechnung für meine Noten zulegen. Mit Excel kam ich da meist gut zurecht.

Ich habe folgendes Problem:

Ich habe z.B. in Mathe einen Schnitt aus allen Klassenarbeiten und einen aus allen Tests. Verhältnis: KA-Schnitt mal 4; test-Schnitt mal 1.

Nun soll daraus der gesamte Schriftliche Schnitt berechnet werden.

In B2 steht der KA-Schnitt; in C2 der Test-Schnitt; in D2 der schriftliche Schnitt.

In D2 habe ich dann diese Formel genommen:

=WENN(UND(B2>0;C2>0;ISTZAHL(B2);ISTZAHL(C2));MITTELWERT(B2;B2;B2;B2;C2);WENN(UND(B2>0;NICHT(C2>0);ISTZAHL(B2));B2;WENN(UND(NICHT(B2>0);C2>0; ISTZAHL(C2));C2;"")))

Denn, wenn nur B2 gefüllt ist, soll dieser Wert auch in D2 stehen; dasselbe bei C2.

Wenn beide Zellen mit Werten gefüllt sind soll der oben erläuterte Schnitt berechnet werden.

Jetzt ist es bei mir aber so, dass, wenn nur in einer der Zellen (B2/C2) ein Wert steht, D2 gänzlich leer bleibt.

Ach ja: Ich habe Excel 2010 und in B2 und C2 stehen Formeln.

Danke für eure Hilfe. Mensch0000000

...zur Frage

Wie cluster ich bei Excel Zellen bei bestimmter Bedingung?

Hey, Ich habe in etwa folgende Tabelle: Obst Kommentar C1 Apfel lecker C2 Apfel super C3 Apfel toll C4 Birne saftig C5 Birne reif C6 Birne billig C7 Birne schmeckt C8

Mein Ziel ist es nun in C2 alle Kommentare zusammenzufassen die zu Apfel gehören als suche ich eine Formel die dann in C2 folgendes ausgibt: lecker super toll. C3 und C4 sollen dabei leer bleiben. Bei Birne soll es ebenfalls so sein. Ist dies mit Excel machbar? Gruss

...zur Frage

Wenn A1=A2="X" Dann "Ja" sonst "nein" Excel Wenn dann formel?

Hallo ich möchte ein bisschen mit Excel rumprobieren und komme grad nicht weiter. Ich möchte ein Tikatoospiel erstellen die Frage ist nur wie sage ich das wen A1 und A2 und A3 X ist gewonnen wenn nicht leer machen kann. =WENN((A1=B2=C3)="X";"Gewonnen";"…") =WENN((A1&B2&C3)="X";"Gewonnen";"…") =WENN(A1=B2=C3="X";"Gewonnen";"…") =WENN(A1&B2&C3="X";"Gewonnen";"…") gehen alle nicht

...zur Frage

Wie kann ich Excel Formel Ergebnisse sortieren?

Beispiel: wir haben folgende Zellen:

A1 --> 2

B2 --> 4

A2 --> =A1+B1 (=6)

A3 --> =A1-B1 (=-2)

A4 --> =B1-A1 (=2)

A5 --> =A1*B1 (=8)

nun möchte ich in der Spalte B die Inhalte der Formelen sortieren:

d.h. in B2=8, B3=6, B4=2, B=-2.

Mit harten Werten weiß ich wie es funktioniert, aber wie funktioniert dies mit Formelergebnisse???

...zur Frage

Excel Zellen sollen nicht den tatsächlichen Inhalt, sondern einen definierten Text anzeigen?

Ich will mit bedingter Formatierung Zellen ansteuern können, die gleichzeitig einen Text anzeigen. Gibt es eine Formel, mit der der tatsächliche Inhalt nicht gezeigt wird?

...zur Frage

Was möchtest Du wissen?