Excel: Teilen zweier Zellen mit Bedingung?

 - (Computer, Excel, Office)

3 Antworten

Du widersprichst dir in deiner Frage.

Also der Wert von C (Bei dem in der Spalte E eine 1 steht) geteilt durch den nächsten Wert von C (Also der Wert, der direkt drunter steht)

Das wäre laut Bild 352,2/353,79

Die Berechnung für das Beispiel in dem Bild (rot eingekreist) würde lauten: 352,2 : 355,67.

Damit teilst du durch den Wert, der darüber steht.

Am Prinzip ändert das nichts. Wenn du mit Nullen leben kannst, wäre es ganz einfach:

D3: =E3*C3/C2

Das kannst du herunterziehen.

Sonst arbeite mit WENN und fang optimaler Weise noch das Teilen durch 0 ab.

D3: =WENN(UND(E3=1;C2<>0);C3/C2;"")

Kurze Frage: Wäre =wenn(E3=1;C3/C4;““) nicht auch korrekt?

Irgendwie spuckt mir Excel aber leere Zeilen aus

0
@SlackCloud

Wahrscheinlich ein Konvertierungsproblem. Die Zahlen in Spalte E stehen linksbündig, was auf Textformatierung hindeutet. 

Ändere deine Variante mal auf 

=WENN(E3="1";C3/C4;"")
1
@SlackCloud

Geht es denn überhaupt ohne Wenn-Bedingung und hast Du's mal rauf- und runtergezogen?

Die Formel sollten nämlich alle gehen!

0

Das lässt sich mit der IF Funktion leicht machen.

=IF(E5=1;C5/C4;0)

Wenn du keine 1 hast wir so einfach eine Null ausgegeben, kannst dir auch alles andere ausgeben lassen.

Ich benutze Libre, sollte in Excel aber genauso gehen.

Ich bin relativ neu im Bereich Excel :D

Also ich weiß aufjedenfall das die Formel mit =WENN(E:E=1) anfangen muss (?)

0

=wenn(E3=1;C3/C4;““)

Genauso hab ich es eingegeben aber ich bekomme nur leere zellen ohne inhalt zurück?

0

Was möchtest Du wissen?